'Top Contributors' leaderboard not showing usernames

Hi! Anyone having issue with the Top Contributor component? It doesn’t display the users profile photo and username. Maybe it’s a bug? I’ve tried uninstall and reinstall the component.

I am as well. I just tried it out, and I can’t get it to even show up: SailPoint Developer Community Forum - Learn. Build. Connect.

@meghna How do I fix this?

1 Like

this TC isn’t working at the moment, so i’ve added the broken tag for the time being.

1 Like

well today this component appears to be working now. i have tested it on my forum in Chrome, Firefox and Safari. :slight_smile:

i didn’t see any updates in the repository so perhaps one of the recent changes in core fixed it. :thinking:

thanks Team!


Hi @Lilly, Still having issues this component. I tested it on Chrome, Firefox, incognito window, and private window.

it my be conflicting with another theme. try previewing it from the component.

also how up to date is your Discourse version?

Same outcome when previewing it from the component. It’s up to date on the Discourse version. :slightly_smiling_face: :thinking: I’ll continue to dig around.

do you have it enabled?

my settings


It’s enabled. I’ll play around with the settings.

sorry i meant is your Discourse up to date with latest stable or beta?

Discourse is up to date with the latest version. Some displaying the user name but some are blank. I’ll continue to poke around. Thanks, @Lilly!

Hello, Is it a forked or modified version of this theme component? I’m asked it because as I know it only shows 6 users, not as many as on your screenshot. :thinking: Is there any error in console? Can you share your site url if it’s public?


Hi @Don here is the site General - Forums. I can uninstall the component and reinstall.

1 Like

that looks forked or really not right. can you check the source for the component and make sure it’s the correct repository? the component has been forked before so make sure you are using the correct one.

oh my… :thinking:

could be some component conflicts there. but i’m surprised it doesn’t work when you preview it from the component if you’re using the correct souce.


Thanks @Lilly! I’ll give it a try.

1 Like

It seems you need to update your forum.

Your forum last update was June 16:
Discourse 3.1.0.beta5 - afa6c0a9a423ce995750fd25b1720f96a89e81bd

There was an update in the core at July 18: FEATURE: Add limit and group exclusion to the directory items endpoint

This theme component is using these parameters here :arrow_down_small:
exclude_groups and limit

The issue is your forum can’t handle these parameters because your Discourse version is older than the change in the core. :slightly_smiling_face:


@Don @Lilly Thank you for your help with this!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.