Top page default timeframe

Setting is non-responsive; I want to show top topics from all time by default. Top page only shows top topics over the last year, no matter what timeframe I choose.

Private forum - v2.2.0.beta5 +48

Where are you choosing the timeframe?

I think he is choosing it in a site setting, however, IIRC, if the default setting can’t return the necessary number of results, it will cycle down the list to the one that can.


Somewhere in admin -> settings (search for «top page»; second result named «top page default timeframe»)

Do you have enough data to populate the list, per @cpradio’s comment?

Also, I can’t reproduce the issue on latest. My sandbox is successfully showing All Time, Quarterly, or whatever I choose in the site setting (there could be an explanation to that, in that it is ignoring insane limits and choosing a safer default – I’ve have to look at the code to figure out if that is happening).

I also played with the number of results and it didn’t seem to make any difference.

Visiting the top page

Choosing All

Visiting the top page


I changed «topics per period in top page» from 50 to 5; and now «all time» is no longer an option from the top page - still gone after changing the value back to 50. I also tried changing it to 1; the system now uses week as the default timeframe. Quarter and year shows 9 topics?

«All time» is now back after changing the value to 50 once again, and refreshing the top page a few times

cpradio, is the sandbox configured as a private forum? Login reguired to view anything; registration disabled (new users by invitation from staff only)

No, it is open to all.

cpradio, the first comment; seems to me that whatever’s working behind the list isn’t registering old/imported topics and posts? The setting in the admin panel is set to show ‘all’ as default, but the top list picks ‘yearly’ by default? I can’t remember the exact numbers, but more than 1000 topics and 30000 posts was imported, so you can see why I’m expecting a different behaviour.