Topic List Previews Theme Component

Nice! And yes, it works. Thanks.

2 Likes

3 posts were split to a new topic: Removal of Ember string prototype extensions

Why can’t I navigate to any categories and encountering errors ?

2 Likes

Ah, sorry about this @Ryan121. I think there’s a conflict with this theme component and a new change in our code that’s not on self-hosted sites yet (which may have caught Robert by surprise :grimacing:).

There was also a similar report here - All links to categories broken?

4 Likes

slightly confused by this - are you saying this breaking change is not on tests-passed yet?

I only support tests-passed with this component (and usually pin for stable which is apparently working for current stable).

3 Likes

(for the record: component has now been updated for the upcoming core change :tada:)

4 Likes

For some time the featured row loads a bit later than the rest of the homepage for us on krita-artists.org This cause the list of thread to jump down and it is a bit jarring. Is there any solution to this or am I doing something wrong.

I believe this is partly a result of changes in core that have forced us to retrieve the data within the Featured Component instead of the Route as previously, so it happens later. This is unfortunate, agreed. There may be a partial CSS solution to make it less jarring. PR welcome or you can sponsor me to take a look.

1 Like

Thank for the quick reply,

That is a bit unfortunate indeed. I do not have the funds to sponsor this now. But I will try to raise something if possible. May I know (in private message may be) what would be an approximate estimate for this task?

1 Like

I’ll drop you a line :+1:

Thank you for the awesome plugin! But there are some issues I can’t deal with. I’m not sure if these are bugs or caused by wrong settings.

  1. When I tried to go back to the topic list, the scrollbar will return to somewhere else instead of the last visit part.
    2.I tried to enable topic list action and they look fine. However, it randomly highlights the bookmark button, even though the topic has not actually been added to bookmarks.

That’s currently not supported. PR welcome

That’s very odd, I cannot presently reproduce - are you on latest version of Discourse?

@Niels_Dewitte sorry this took so long, but a PR was always welcome to fix this.

Thanks again for the report. This should be resolved now.

2 Likes

Hi, how do I use the thumbnail picker in GitHub - paviliondev/discourse-topic-previews-sidecar: A Discourse plugin that complements the Topic Previews Theme Component to add features?

2 Likes

It’s a button in the topic meta editor:

1 Like

This button is not shown on my discourse forum, i’m currently using:

Installed

3.2.0.beta4-dev

(d03f6727b1)

1 Like

I have, and I rebuilded few hours ago.

I know. That doesn’t help you a bit, but it means your issue isn’t by some general bug.

2 Likes

@merefield

I noticed that your recent changes from two weeks ago removed the usage of the Ember global. However, it will fail if you use Ember 5!
For example:

Suggestions:

  • computed.boolbool@ember/object/computed
  • run.scheduleOncescheduleOnce@ember/runloop
3 Likes

Nice catch @Arkshine! This deprecation is deprecated-run-loop-and-computed-dot-access. Messages about that would’ve shown up in development and test environments, but it looks like they were being optimised out of the production build.

This will make the warning work in production builds of Discourse under Ember 3.28:

(by default Ember optimises all deprecations out the production build, so we have a to do a lot of work to undo those optimisations)

2 Likes

Thanks David. Yeah that would be why I will have missed them. As a Theme Component I generally check for deprecations against a current Production build as I use the Theme CLI (and none of my Production builds are running Ember 5 just yet so …).

Great catch @Arkshine !

2 Likes