Topic toolbar popup menu does not show

Dear Discourse community,
for an unknown reason we can not use the toolbar popup menu in our Discourse instance. I hope that maybe anybody has an idea what could be wrong.

I am talking about this menu when you create a new topic. This is a screenshot from


However in our instance it now looks like this:
(This bar is also loading like the loading bar on top of the page.)

bug toolbar

Also there is an error in the console:

When I put a breakpoint on the first error in the console I get this:

Here is the code in the dev tools of my browser:

Things I tried already, but did not change anything:

  • Disable all Plugins
  • Disable all Theme Components
  • Remove all custom CSS
  • I tried to google and find if anybody has this problem.

The version of Discourse is 3.3.0.beta2-dev.

Any hints are appreciated!

IN one of your screenshots “scrollable post content” is causing problems. And it’s github repo says “This repository has been archived by the owner on Nov 16, 2021. It is now read-only.”

So maybe you didn’t really disable all of the theme components?


Hello, welcome to Meta :wave:

You can use safe mode to properly test whether the issue is from a theme component or a plugin.

As Jay suggests, the Scrollable Post Content might be the cause of this issue.


I confirm this is the cause. I tested on my local dev instance.

I will mark the component as broken. It requires some update!


Yes, you were right. This theme-component caused the issue. I must have missed it. I am sorry to have bothered you.

Thank you so much for the quick reply and extra sharp eyes!!! :yellow_heart: (I was already quite desperate after many hours of trouble shooting.)


No worry. I will see If I can update it later. :+1:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.