Turkish character problem in title


I have a problem as below;

site language is Turkish.
when i paste a word as a title like GIDA it shown as gida. But it must be gıda. Because GIDA has I not İ.


Any idea please.


This happens when the title has only uppercase letters, the site setting title_prettify is enabled and the site setting allow_uppercase_posts is disabled.

Ruby has an optional parameter for String#downcase that we could use when the default locale is Turkish, but I’m really on the fence here. What if someone uses “CIA BLA BLA” as topic title on a Turkish forum?

So, here are some solutions for you:

  • Don’t use all uppercase letters in titles: “GIDA BLA BLA bla” would works fine!
  • Or enable the allow_uppercase_posts site setting
  • Or disable the title_prettify site setting

thank you.

So there is no solution until you mentioned below is live. Right?

it is just a example :slight_smile:

i will use discourse as a wiki for a project, only way is coping texts from somewhere and all titles are uppercase :frowning:

this may be so ugly :frowning:

but i need this :slight_smile:

I am going to change this to #feature

The feature request here is to support title_prettify when a site’s locale is set to Turkish.

I think this is a reasonable request as long as you can help us set out where the rules in core diverge for cases where the locale of the site is Turkish.


Thank you.

It is a pleasure for me.

I can share a list with you.


I prepared a list. If it is not enough, i can do more. thank you.

title_prettify_turkish - Sheet1.pdf (52.2 KB)

1 Like

I say if SiteSetting.default_locale is set to tr_TR it makes sense to use :turkic versions of downcase / capitalize etc in TextCleaner

Seems like the right thing to do. I guess if we want to provide an escape hatch we could make a hidden site setting to disable this on Turkish sites that use English titles.

Do you want to take this @gerhard ?


Problem solved. Thanks again :relaxed: