Turn off 'Show Full Post' in WP Discourse Plugin


(James Cook) #1

I’ve recently noticed that a ‘Read full post’ button has appeared in Discourse topics linked to Wordpress articles.

Is it possible to have this as an option that can be turned off?

2 reasons for this request:

  1. I use Visual Composer in Wordpress to build some posts so they don’t always appear correctly in Discourse
  2. I’d prefer people to have to click the link and visit my Wordpress site rather than staying on the forum

Cheers!


(Tobias Eigen) #2

Isn’t that configurable in the wp discourse plugin?


(James Cook) #3

Not that I saw. I did check! Did I miss it?

Edit

There is an option to show the full post instead of an excerpt. However there doesn’t appear to be an option to remove the Show Full Post button when you are only displaying the excerpt.


(Simon Cossar) #4

You need to disable the ‘embed truncate’ setting on Discourse. It’s found under admin/site_settings/category/posting.


(James Cook) #5

Thanks.

That has removed the button from my existing topics.

However, does this also have the effect of not truncating my future articles?

I’d like them truncated, but I don’t want to show the button…


(Simon Cossar) #6

No, the setting is a little confusing, Disabling ‘embed truncate’ on Discourse has no effect on what is being published to Discourse from the wp-discourse plugin. As long as the ‘Use full post content’ setting is not enabled on WordPress, only excerpts of your posts will be sent to Discourse.

If you’d like to set the content of the post excerpt on WordPress, make sure that ‘Excerpt’ is enabled under ‘Screen Options’ on the WordPress post-new page. You can then add the content that you would like to be published to Discourse to the ‘Excerpt’ meta-box on that page.


(James Cook) #7

Thanks once again @Simon_Cossar :thumbsup:


(Jeff Atwood) #8

We should improve the help copy (the setting description text) here if we can.


(Tobias Eigen) #9

I just fell prey to this myself. The “show full post” button on my site decided to show the privacy policy from my site, and not the full post. So I had to disable it. I went to search admin settings for “show full post” but it is not included in the helper text so shows no result. I had to come back to this post to get the answer. Thanks, @Simon_Cossar!

So… agreeing with @codinghorror that the help copy should be improved, at least to include the keywords “show full post”. For the rest I don’t fully understand how this functionality works and will leave it off on my site for the time being.


(Patrick Klug) #10

Just adding to this, since I just had nearly the same experience. The show full post button on our site also displayed only the legal lines of the footer from our website, nothing else. Without this topic, I would not have found how to get rid of the button.


"Show full post" does not show correct data
(Simon Cossar) #11

Yes, I think there should be an option to disable this behaviour on the WordPress end, without having to unselect the ‘embed truncate’ setting on Discourse.

If the plugin doesn’t send the embed_url to Discourse when it publishes a post, then the Show Full Post button won’t show up on Discourse.