Twitter link expansion shows image of user profile

When I post a link to a response in a topic that doesn’t have an image, it puts the user profile image. So in my case, the link expands to have a big picture of my face on Twitter. That’s not exactly what i’m trying to highlight :wink:

Is there a way to override that?

The twitter avatars at the moment are bit … big … I am fixing it now


That’s great. But rather than size, can I not have my face show up at all? Can it just be blank? Or use my site logo?

Let’s quickly check:

A theme component with

.twitterstatus .onebox-body .thumbnail,  .twitterstatus .onebox-body .aspect-image {
   display: none;

Should probably do the trick.

But we really should be showing it like this, which I am fixing:


Sorry. I should have been more clear. My apologies.

On Twitter, the link expansion is my issue. I don’t want my avatar being on the expansion. I want to prevent my avatar picture from populating that image spot.

25 PM

That is by design, we include the avatar of the user in our opengraph data and twitter render it that way. There are no toggles to disable us providing this metadata.

So if I put some kind of picture in that post, that will overwrite the avatar image, yes?

Yes that is how it works, we fall back to user avatar.

1 Like

Look much better now, closing this.

1 Like

This topic was automatically closed after 23 hours. New replies are no longer allowed.