UI not loading after git pull update

Just ran a git pull and rebuild my discourse instance. Webserver is running. Background loads. But there is no UI. Pretty much nothing in the body tags loads. I’ve tried rebuilding the app and restarting my server. Still an issue.

Is there any difference if you try

I’ve had some trouble with my theme components after updating recently, it showed up as error messages in /var/discourse/shared/standalone/log/rails/production.log


Thanks. This is helping. I tried every combination of the three toggles on the safe mode page. The only combination where it still doesn’t load is when I disable my current theme but don’t disable unofficial plugins or all plugins. Does this mean it could be an issue between an official and unofficial plugin?

I haven't touched the plugins in a while. From my memory, I don't think I was running any unofficial plugins. This is wrong. I’m disabling one plugin at a time and rebuilding to see if I can isolate the issue.

I don’t see the word “error” in either production.log or production_errors.log-20190121 under /var/discourse/shared/standalone/log/rails/

Any ideas?

1 Like

Looks like I did have an old plugin screwing things up. Once I disabled it and rebuilt the app, the site works fine now. Having a minor issue with the color of the borders for the posts and topics list, but that is easily fixed with some css tweaks.

Thanks for the help.


If the plugin is listed in #plugin do let us know which it was, as it may need to be tagged #plugin:broken-plugin.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.