Unable to set notification type for group message inbox, again


(Felix Freiberger) #1

This issue is back from the dead:

Now it’s happening in Discourse 1.6.0.beta7. The reproduction steps are still the same, the error message is still Uncaught TypeError: Cannot read property 'setNotification' of undefined.


Somehow, after reloading the page, I ended up tracking the inbox, and could switch to watching…


(Felix Freiberger) #2

This is still an issue; but this time, I could not get the state to switch to tracking.

Here’s a screenshot of the inspector:


(Jeff Atwood) #3

Can we repro this @techapj?


(Arpit Jalan) #4

Unable to repro this issue here on meta (for team & moderators group) or on try (admins group).

Just curious, did reloading the page solved the issue?


(Felix Freiberger) #5

Every time I tried to switch the notification mode, a new copy of the error was thrown on the console. Reloading didn’t fix it on the first try.

After trying a few different notification state and navigating to the archive and back, after reloading, I was tracking the inbox.

It’s interesting that you cannot reproduce it, while I could reproduce it multiple times. The only details that are interesting about my case:

  1. login required
  2. SSO is enabled
  3. I was always testing it for a fresh group, after sending it a test email to make the inbox show up.

Is there something I can do to help you debug this?


(Felix Freiberger) #6

Could you maybe try that again with a new group? I think that’s the most interesting difference between your experiment and my experience…


(Arpit Jalan) #7

Just tried locally, still not able to repro this issue :confused:


(Felix Freiberger) #8

Strange. I tried to reproduce it again, and failed – so it seems to be sporadic.


(Felix Freiberger) #9

I just set up a fresh Discourse instance, and hit this again. Here’s what I did last:

  • create a new group
  • set up incoming mail for the group
  • send a test mail to the group
  • open the notification that there is a message in my inbox
  • try to set the notification level from there


(Felix Freiberger) #10

I can no longer repro this.

However, I can no longer update the tracking state for someone else (by visiting their messages page). The change appears to work, and there are no errors in the console, but the change reverts when the page reloads. Instead, I changed my own tracking state for this group.


(Sam Saffron) #11

Can you do a separate topic on this issue?


Changing tracking state of group inbox updates your own tracking state instead
(Sam Saffron) #12

(Jeff Atwood) #13

(Felix Freiberger) #14

I’ve just run into this again:

So it looks like the bug is back, or was never really gone.

An observation I made: This only occurs if the level is still at the default. It never happens once you successfully updated a group’s notification level once.

Is there anything I can do to help you debug this?


Notification Settings for Groups - Seems to be two separate settings