Updates to SSO settings not saving

We previously had the “SSO overrides username” and “SSO overrides name” options checked in our Discourse settings, but I wanted to do some testing with those specific settings unchecked. (I am leaving certain SSO things checked though, like “overrides email.”)

When I uncheck those settings and save, I refresh the page and those settings are checked again. I also tried doing the “Reset” and save to uncheck them, but the settings still didn’t save after a refresh.

This does seem weirdly inconsistent though, because occasionally I’ll see the update save correctly, test with it for ~10 minutes, then go back to Settings to see and it’s reverted again. I’m still trying to figure out any sort of pattern here and triple check that there’s no config on our side that could be doing this (I don’t think there is), but in the meantime, has anyone else seen this type of behavior in Settings? Any idea if I’m doing something wrong, or if it’s a potential bug?

Edit: The settings appeared to stay correctly unchecked for awhile (over an hour), and then as soon as I navigated to my Account page to see if I could edit my name/username fields, the settings seemed to constantly waffle back and forth between being checked and unchecked. Thus I could sometimes edit my name/username fields, and sometimes not. Not sure if it’s a coincidence, but the problems appeared to start again when I went to my Account page to edit things.

1 Like

Are you still having trouble with this? As long as you are clicking the checkmark icon to save the settings, they should not be getting overridden after you update them. Have you noticed similar issues with any other settings on your site?

1 Like

I just did some more testing and I am seeing it happen with other settings. The ones I just tested were non-SSO related - “Allow users to choose their own language interface preference” and “Display user consent prompt” for the push notifications prompt. The same thing happened with these - unchecked them, saved with the checkmark, came back to the page a minute later, and the changes were not saved.

We haven’t seen this in the past with our settings, though we don’t make updates to them very frequently. This is on Discourse version 2.7.0.beta1.


This sounds like a bug. If you go to your site’s error logs page (Admin / Logs / Error Logs) do you notice any error messages that seem like they could be related to the issue?

Do you have any non-official plugins installed on the site?


Not seeing any errors since December 30. The most recent warning happened yesterday, though I don’t think it’s related.

MaxMindDB (/var/www/discourse/vendor/data/GeoLite2-ASN.mmdb) could not be found: No such file or directory @ rb_sysopen - /var/www/discourse/vendor/data/GeoLite2-ASN.mmdb

We have four official Discourse plugins installed - Docker Manager, Discourse Solved, Discourse Chat Integration, and Discourse Data Explorer.