Upload button remote external image URL field not showing

Previously when we were clicking the upload button, we get an option to either upload the images from our computer or paste a link to get image from a public URL, but now that upload button when clicked is only showing upload from computer.

OR e.g We have to manually do it like this now

![alt text for the image](http://url/to/img.png)

We know you guys did an update here Faster (and smaller) uploads in Discourse with Rust, WebAssembly and MozJPEG | Blog

but please add that option to paste a image external public URL field for users so we can paste a image link from external CDN too, not all users know how to use the markdown syntax and hence users are not able to upload images on our site, as we have already turned off file most image file extension uploads to avoid our server storage getting extra.

We rely 100% on external CDN images e.g https://images.unsplash.com/photo-1485988412941-77a35537dae4?ixlib=rb-1.2.1&ixid=MnwxMjA3fDB8MHxwaG90by1wYWdlfHx8fGVufDB8fHx8&auto=format&fit=crop&w=1072&q=80

OR

![alt text](http://url/to/img.png)

That was removed on purpose as it required extra clicks for the local upload user flow, which is the predominant use case.

You will need to create/commission a theme-component if you want a wizard to create image external image markdown code.

We really do need the old functionality, our site is very small and we don’t allow file uploads for images so we use CDN images from copyright free sites. if you guys can enable that view in the UI dropdown, it will be super helpful for entire community.

Just requesting a theme component for something which already existed doesn’t seem logical to me. and infact paying for the same which already existed in Discourse core.

My request is to please add that view back, and perhaps add an option in admin settings to show or hide that view if other users want newer view. so in our case we will select the option to let us see both views, file upload + CDN image url link upload from same button.

Thanks in adv, @Falco

i’m also seeing this bug

1 Like