User following invitation link is not visible in Admin/Users due to SSO

I have sent out multiple invitations for the new forum. For this I have generated a link, saved it and send the link via Email to my colleague. She clicked on the link and registred. But I just don?t see her in the overview page of Admin => Users.

What am I doing wrong?
I already asked my colleague to sign out and re-login but nothing changed.

The User directory is generated periodically on a schedule for performance reasons. Users not appearing immediately there shouldn’t be a concern, unless after 24 hours you don’t see the user.

There’s a hint that this is the case in the title, where it says “Last Updated:”

What does “Last Updated” say for your users page?

Good Morning Jeff
My colleague registered last Friday (28/05/21).
The current User directory says “last updated 31/05/21” - and she’s still NOT on that list.

I need her account to appear there as I have to give her permissions. Is there a setting that might be wrong and which I can check?

I’ve just spoken with my collegue who mentioned that it might be a problem that we’ve activated SSO between our main system and the forum. It’s just confusing that people are able to register but do not appear on the users list

1 Like

Is this a staged user (email only) or a full user account? Is there anything unusual about the account?

I also made an error in my previous response, I referenced the public user directory, I didn’t notice you were referring to Admin → Users, the private user directory, which is even more strange.

To be honest, I don’t know the exact difference between a staged user and a full account.
I guess it should be a full user, a moderator at the end, once I can give her all the permissions she needs.

Received the latest of the daily updates this morning, but user is still not appearing on that list.

We need to invite more Users later this week. Do you see a chance we can find a solution?

As you are a hosted customer, this is best handled through direct support, and someone from our team has contacted you – follow up there.


Just adding a note here to say that the issue seems to be that when invites are sent from a site that is using DiscourseConnect for authentication, users are logged into Discourse through the SSO provider site when they click the invite’s “Continue” button:

This means that their Discourse account is not actually created until they go through the authentication process on the SSO provider site. This is the expected behaviour. When DiscourseConnect is enabled users can only login to Discourse through the SSO provider site.

I’m not sure what could be done to make the process more clear. If the invited user doesn’t have an existing account on the SSO provider site, the process could be quite confusing.