Very, very slow on local machine (fresh install)

Has anyone experienced *extreme slowness" issues after a new local install? I just completed a fresh installation am trying to create a theme. I’m not super familiar with Ubuntu/WSL so maybe I’m missing something obvious?

Build successful (213157ms) – Serving on http://localhost:4200/

Slowest Nodes (totalTime >= 5%) | Total (avg)
-+-
@embroider/webpack (1) | 88353ms
Babel: discourse-plugins (19) | 54321ms (2859 ms)
DiscourseScss (2) | 25401ms (12700 ms)

I, [2024-04-01T12:37:00.055056 #9162]  INFO -- : SIGWINCH ignored because we're not daemonized
I, [2024-04-01T12:37:02.447649 #9162]  INFO -- : SIGWINCH ignored because we're not daemonized
Killed
[bin/ember-cli] ember-cli process stopped. Terminating unicorn.
I, [2024-04-01T12:37:54.128930 #9162]  INFO -- : reaped #<Process::Status: pid 9501 exit 0> worker=2
I, [2024-04-01T12:37:54.239701 #9162]  INFO -- : reaped #<Process::Status: pid 9500 exit 0> worker=1
I, [2024-04-01T12:37:55.360116 #9162]  INFO -- : reaped #<Process::Status: pid 9499 exit 0> worker=0
I, [2024-04-01T12:37:55.362898 #9162]  INFO -- : master complete
annetters@DESKTOP-S5K8606:~/discourse$ 
2 Likes

Can you share memory stats while running this? 8GB is already tight for Windows 11 alone, if you add the whole Linux VM to run WSL2, and the PG/Redis/Unicorn/Ember processes it may cause you to swap too much.

Maybe try developing your theme against our Theme Creator, create and show themes without installing Discourse! ?

6 Likes

Eep. Good call. This doesn’t seem great.

image

1 Like

lmao, chrome enjoys being a good memory hog

1 Like

If you are keen on developing against a local instance, I’d look into dual-booting Linux if you can afford the disk space. It’s what I do personally.

Otherwise your best bet is using Theme Creator, create and show themes without installing Discourse!.

3 Likes

I’ve only a Discourse small dev instance for comparison, and WSL already uses 4GB. However, the actual usage can be much higher depending on the activity in it.

image

I would definitively follow Falco’s suggestion if you can.

On a side note, you can adjust the WSL configuration (such as limited memory, swap, etc.)

1 Like

It shouldn’t be, the amount WSL uses is just reserved for itself, and AFAIK, it won’t go over it’s reservation…

I’m not sure. Maybe it was a bug before, but I usually never turn off my computer, and for some reason, it could go up to 10GB (or more). But yeah, by default, from what I see in the documentation, 50% of your total memory can be used. (I have 64 GB, so I guess that’s the reason).

Hey all. Thank you for your suggestions. I ended up developing the theme separately via theme creator and testing components on a hosted install. Guess I’m shopping for a new laptop with more membory this year! :slightly_smiling_face:

1 Like