I'm having trouble installing a local Discourse instance on Windows 11

Hello. I’m a developer that just recently discovered Discourse.
I’m having trouble getting a local instance of Discourse to work on my Windows 11 machine. This local instance will be used to model and edit a custom theme for future development.

Method 1: I tried using Docker Desktop, but the commands listed on the official Discourse guides are not working for me. The container doesn’t start.

Method 2: I tried Ubuntu in WSL but I encounter all sorts of problems, from ruby gems not correctly installing, to version problems (Discourse runs on Ruby 3.2 and for some reason the Ubuntu installer goes for 3.0.2).

Is there incompatibility with Windows 11? Am I missing something?

TLDR: I want to install a local instance of Discourse in my Windows 11 machine to modify CSS and show the theme changes to my employer. Help!

Thanks in advance!

1 Like

Under a WSL environment you need to follow Install Discourse on Ubuntu or Debian for Development

Why not Install Discourse on Windows 10 for development?

If you read both you will see that the Windows guide is basically telling you to open WSL and follow the Ubuntu guide :slight_smile:. The Ubuntu guide has been reviewed recently by our team and attested to be working, and it tracks very closely what the developers here at Discourse use in day to day developments.

1 Like

You’d be much better served to just use Bugs theme-component and do the work on your public instance or another standard install.

1 Like

Thank you all!

I actually followed the guides that Discourse provides, step by step, but clearly I’m doing something wrong!

I will keep on trying, and try out the method that @pfaffman pointed out.

Thanks and sorry for the newbie questions!


Don’t be sorry for that! Every question is welcome here (bonus point if used the search before asking though :stuck_out_tongue: ).

We try to keep the dev install guides up-to-date, but sometimes they aren’t.

I’ve also encountered issues when installing it on Windows at times. It’s possible that you properly followed the steps but something is wrong in your configuration, or the guide needs to be checked up.