Website crashed while updating


(Prateek) #1

Hi,

I just tried to update my discourse forum, and it did not succeed.
Following is the screenshot i took before my website messed up (and still is down) :expressionless:


(Sam Saffron) #2
cd /var/discourse
git pull
./launcher rebuild app

Make sure you have 2GB of swap space per howtos here.


(Prateek) #3

Yes, i do have a 2gb swapspace. Let me run these and i’l get back asap


(Prateek) #4

Did not work. Site still down.


(Sam Saffron) #5

Nothing I can do here, without clear logs showing where the error is.


(Prateek) #6

Please tell me the location of the logs so i can paste it here


(Sam Saffron) #7

The logs appeared on your screen…


(Prateek) #8

Eh??
Sam, what can i do to fix this? I understand logs are needed, but i don’t have them. What can be done here?


(Sam Saffron) #9

You ran:

cd /var/discourse
git pull
./launcher rebuild app

A whole bunch of stuff appeared on your screen, towards the end was the actual error.

I need that.

You can run it again if you need.


(Prateek) #10

Phew. It’s fixed this time i ran ./launcher rebuild app. Thanks Sam

A question - Is it recommended to upgrade to a “beta” update? I’ve always seen beta updates on my discourse like “v1.6.0.beta10 +58” . Are these stable or is it recommended to wait for stable versions?