"Welcome Setup After" Digital Ocean Server Reboot? Cannot Dismiss


(Eric Saliba) #1

Images stoped loading on my site and whenever I go to login via SSH I’m greeting with a “Welcome Setup” kinda screen that reads:

Thanks for using the DigitalOcean Discourse Application Image.
To get started, the following configuration details will be required.

  • Email Address for the Discourse Admin Account
  • The hostname (domain or subdomain) you will use for Discourse
  • Details for the SMTP server your Discourse install will use to send email

Please press enter when you are read to configure discourse.

How do I get past this? I did force the server off and got the images to come back but I do not want to reset everything again to get past this message when I try and login… Any help is appreciated to remove this message! What should I do?


(Joshua Rosenfeld) #2

You should be able to Ctrl + c to bypass that.


(Eric Saliba) #3

Thanks! Is there any reason this popped up a few days after I installed Discourse and how to I make sure this doesn’t come up again?


(cpradio) #4

From what I recall, this will appear everytime you SSH into the machine. It is due to how Digital Ocean’s Application Image works, you will always have to CTRL + C to get out of it.


(Joshua Rosenfeld) #5

We (Discourse) did not make that image, Digital Ocean did. You’d need to ask them how to prevent it.


(Jay Pfaffman) #6

I think that somewhere in the text that’s spewed, it tells you how to make it stop.

The recommended course of action is discourse/INSTALL-cloud.md at master · discourse/discourse · GitHub.