When creating new category with "staff" permission, it is only setting the permission to "everyone"


I’ve successfully created staff categories in the past few weeks. However, now when I just tried to create another category for staff only (“staff announcements”) the security setting of “staff” is not applied. After creating the category, the permissions are still set to “everyone”.

Is there something obvious I’m missing here?

Any help would be greatly appreciated!


Can we repro this @jomaxro?

Nope, no repro. Just tested in try.

Hi Joshua,

I just tried again and it seems that I’ve got it sorted now. Apparently I was not performing the additional “click” to add the staff permission after setting it with the dropdown menu. That’s purely user error, so my apologies. Thanks for your
time in testing though. I should have done more on my end. Ultimately I think my expectations were off since I was expecting the setting to be saved after choosing “staff” from the drop down, rather than having to then click “add permission” after setting
the dropdown. I figured “add permission” would literally want me to add an additional permission field.

We’re all good now.


You’re not the first person to run into this: Auto-add permissions/unsaved permissions prompt. Maybe the UI for adding permissions could be improved.


This topic was automatically closed after 2 days. New replies are no longer allowed.