When I start a conversation with the AI, it gives two answers to my question

I am encountering a small anomaly. It’s been like this for a long time but I didn’t pay much attention to it. Now I had time to report this. When I start a conversation with the AI, it gives two answers to my question. This maybe because of my configuration. But I couldn’t find a logical explanation for it. I’ve checked the settings multiple times. What do you think might be causing the problem?

Sorry, this seems to be for a different plugin

The official ai plugin does not support this mode. What plugin are you using ?

1 Like

looks like it might be

1 Like

I think it’s related to this plugin, I tried it, I turned it on or off:

@Lilly I thought about this and closed that plugin, it is related to the setting in the picture above, when it is active, the feature opens.

@sam @Lilly
Now I noticed that when I close the chatbot plugin, the two are not responding. The problem disappears. This error or problem may be related to the chatbot.

1 Like

Why are you installing both? That’s not a tested configuration.

I cannot reproduce this issue on Chatbot. Discussions in PMs are just giving one reply.

Please note that Chatbot does not explicitly support multisite


I tried turning off the chatbot plugin. You can see the difference below. I guess I have to use both, because my goal is for users to interact with artificial intelligence. I hope this topic will be useful for the development of plugins in the future.

Without Chatbot (same question):

With Chatbot (same question):

Please uninstall Discourse AI (for the time being), rebuild and retry (this will potentially rule out a clash)

Also, please confirm you are using the standard install?


Could the problem be caused by it? I made the bot user the same in both applications. When the ai plugin is installed, it automatically creates a network chat user. I changed it and made the name “kompiter”. I also used this username in the chatbot plugin. I think this may be the reason why you got two answers. I’ll test a little. I’ll be right back.

As I thought, when I turn this setting off, the chatbot gives a warning when I talk with the private message “Allow Chatbot to interact in Private Messages”, the error in the picture is: It is not allowed to be used in private messages, please contact the administrator.

and I’m guessing, changing the username in the chatbot makes this work go away.

If artificial intelligence can help in everything without a chatbot, I can deactivate that plugin for a while. However, when I deactivated the chatbot, it did not answer a simple question. I have to observe and prove this a few more times. Then I can draw a conclusion.

I closed the chatbot plugin and started testing. I will convey my observations and conclude this issue.

You still haven’t answered this question:

Also I don’t think you can reuse the same bot username.

You are using Chatbot in a way it has not been tested, designed nor intended.

It is working fine on a standard install without Discourse AI and with its own username.

1 Like

I’m sorry, I forgot to answer this question when I realized what the problem was. I always do a standard installation. I stay away from non-office installations.

The reason I got two separate replies in private messages was because I made the users created in discourse ai and chatbot plugins the same.

When I activate the private message support in the chatbot, since the usernames are the same, the discourse ai answers first, and then the chatbot answers.

If I make the users different, the problem will be fixed.

I have canceled the chatbot for now. At this stage, discourse ai is doing my job. It would be nice if only some features in chatbot came to discourse ai :slight_smile:

Answering us when we ask questions to AI while writing answers on the topics.

Sorry for taking your time, but it’s been a constructive topic for me. Thanks.

1 Like

I’m not sure why you expected that to work.

So what happens if the usernames are different? Please give chatbot its own unique user id.

1 Like

First of all, sorry for my bad English;

When I start a private message, since the chat user of the two plug-ins is the same, the chatbot plug-in also responds to the private message (since the pm interaction setting is on).

The conflict here is because I made the usernames the same.

As far as I remember, discourse ai automatically creates bot user. I changed his name and then defined the same username in the chatbot.

Since the pm interaction is turned on in the chatbot settings, it automatically responds to the pms I start with discourse ai, because the users are acting as they are referring to itself because they are the same.

My suggestion:

In this case, if the users of the two applications are different, then the error disappears. However, this will create confusion. Two AIs in one site, himm.

Instead, we can make the bot users of the two plugins partners. The problem goes away when we turn off the pm interaction from the chatbot settings. However, when we turn off this setting, it throws a warning message “pm interaction is turned off”. I think it would be enough to just turn off this warning message.

The users will definitely need to be different - so two different bot users completely.

That may not solve the problem though. Does turning AI Bot off solve the problem?

No, we can’t turn off that warning message I’m afraid as that will affect regular users of chatbot.

1 Like

Actually, the only problem here is that the chatbot sends a warning message when the pm interaction is turned off. Otherwise everything works fine. For friends who may have the same problem, my suggestion is to turn off the chatbot pm interaction setting and fix the error message a bit. Or as you suggest, the users of the two plugins should be different.

I have now deactivated the chatbot, but I can refine the error message and reactivate it. I’ll mark the issue as resolved for now.

Thank you for your time, it helped me gain a different perspective.

That’s not a problem though?

If you are trying to talk to the bot and this is disabled, of course it needs to send a warning message?

You want the bot to stay silent and the user be confused why it doesn’t respond?!

1 Like

In fact, the artificial intelligence in discourse AI is already responding. That’s why I think the chatbot plugin doesn’t need to report that “pm interaction is turned off”. There is a choice here. Both plugins have bots and you should be able to choose which one you want to use in private messages. When you do this, it would not be correct for the other plugin to give a warning.

Maybe we can add a control: if the chat feature in discourse ai is turned on, the chatbot pm should not give a warning. like…

In fact, a simple customization for the pm section used by the two plugins would be good. It’s just that the error message is not displayed. Of course, an error message can be displayed if the chat feature in discourse ai is turned off.

I think simple, but a logical result seems to occur.

Please submit a PR but make sure it works without Discourse AI installed too. Thanks.

1 Like

I’m trying to send him a pr on github as I think the plugin that should hide the error message is chatbot, but I couldn’t. (maybe because I’ve never done it before) a good and wonderful person maybe can do it for me :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.