WP Discourse plug in being odd

New posts are creating new topic in discourse but the link to start the conversation is not showing and instead I get

Comments are not currently available for this post.

If I jump to the plug in I also get this error ? But it is connected as its creating topics at least.

You are not connected to Discourse. If you are setting up the plugin, this notice should go away after completing the form on this page

1 Like

I also noticed this in discourse

We detected an API request using a deprecated authentication method. Please update it to use header based auth.

Have you updated wp-discourse lately?

Yes I believe everything is on the latest updates…

also noticed this in blog post

There was an error returning the category list from Discourse

I have deactivated plug in, recreated webhook (which is green) and made new API key. Didn’t help

2.4.0.beta7

(58b5d1434b)

Wordpress 5.3

Plugin 1.9.7

Was it working before you upgraded WordPress to 5.3 yesterday?

3 Likes

The WP Discourse plugin shouldn’t be causing this warning. All API requests from the plugin are using header based authentication. In any case, this is just a deprecation notice. Authenticating API requests with URL parameters will continue to work in the near future.

Can you check that the user you have entered for the plugin’s Publishing Username setting is still active on Discourse? To do this, go to the user’s admin page and look at the Activated row of the Permissions section. If Activated is set to No, click the Activate Account button.

6 Likes

It was working in the past and this was before upgrade but I cannot say the two are linked

its the only API request thing I have… but the user was deactivated… and that has fixed it thank you so much - hmm why would that have happened . Thank you so much

1 Like

The notice may have been created before you updated the plugin to version 1.9.7. I’ll keep an eye out for that notice to make sure that it’s not being generated by the current version of the plugin.

This is probably related to the Discourse invalidate inactive admin email after days site setting. There have been some recent changes that could affect accounts that are only used for connecting to the API. I believe that this issue was fixed in a recent update.

5 Likes

FYI this user got deactivated again. I am however now updating to latest discourse

1 Like

Was deactivated - again reactivated and updated again to latest discourse…

It seems wrong that the user was deactivated again. My understanding is that re-activating the user by clicking the Activate button should keep the user active for the period of days set by your invalidate inactive admin email after days site setting. Can you double check that setting to make sure it’s set to its default value of 365 days? Also, let us know if the user becomes deactivated again.

2 Likes

I checked that setting is 365. I noted account was inactive again. reactivated and updated discourse (again)

2 Likes

I’m looking at the code that invalidates inactive admin accounts now. One thing to note is that you can bypass having inactive admin account emails invalidated by setting invalidate inactive admin email after days to 0. I don’t think this is the ideal solution though.

Admin emails should not be invalidated if the API Key for the admin user has been used within the period of time set by the invalidate inactive admin email after days setting. Is it possible that on WordPress you have set the Publishing Username to the admin account that is getting deactivated, but for the API Key you are using the All Users API Key? If so, it would make sense that the admin account keeps getting invalidated.

Unless you have a reason to not use the All Users API key on WordPress, you could change the values you have set in the WP Discourse connection settings to use your All Users API Key and your system user’s username. That username defaults to ‘system’.

2 Likes