Akismet filter misses so frequently; how to disable/improve?

Our system user has the resounding approval rate of 94% :-1:. The akismet filter just completely misses on a lot of technical posts like this one — that’s a post by a TL1 user who has been around for 8 months with no outbound links. At the same time, it’s missing obvious spam with direct links to gambling sites.

We’ve tried disabling Akismet because it just creates extra work: we get far far more false positives than true positives. But that doesn’t seem to work; new topics like the above are still getting flagged, even though we’ve set “skip akismet trust level” to be 0.

Now that I’m looking into this I see we still have the default 50-post skip setting; I’m unsure how those settings interact. Is there an implicit “AND” between those two settings?

1 Like

No, looking at the code reveals that posts are not checked if either of those settings is true.

However, (to my surprise) there is a hardcoded rule so it always checks the first post of a TL1 user, regardless of skip_akismet_trust_level setting.

2 Likes

I can’t speak to the technicals of our implementation of Akismet, but I do believe we send feedback to the algorithm when you select a flag option. As you verify spam and ham posts through the review queue, you’re helping train Akismet.

1 Like

@mbauman how do you find the system user approval rate? I’m sure our number would be worse. I’m not sure I remember ever having an Askimet-flagged post actually be spam. And BTW our settings are at this & still seeing posts being flagged (I’m about to adjust the trust level to match yours.)

1 Like

The rate appears on the flagged items themselves:

image

Glad to hear it’s not just us — is something else going sideways here? Or is akismet just not as helpful these days?

1 Like

Looks like this should be able to be worked around with:

Could a new version of the Akismet plugin including this patch be tagged/rolled-out to hosted customers?