Beta8 upgrade stuck halfway


(Adam C. Engst) #1

I started upgrading through the Web interface, first docker, which went fine, and then the main Discourse upgrade to beta8. That seems to have gotten stuck (for 30+ minutes, with no change) in a “compressing” phase.

The site seems to still be working mostly, although I couldn’t get to a private message. I’m planning to click Reset Upgrade unless someone says not to right away. :slight_smile:

Here are the last two lines of the log:

Compressing: locales/sr-53d537749608d7dfdfcd3a2581d2afb1dfa2447813239a81a56398a9e6b6e5e6.js
uglifyjs '/var/www/discourse/public/assets/locales/_sr-53d537749608d7dfdfcd3a2581d2afb1dfa2447813239a81a56398a9e6b6e5e6.js' -p relative -c -m -o '/var/www/discourse/public/assets/locales/sr-53d537749608d7dfdfcd3a2581d2afb1dfa2447813239a81a56398a9e6b6e5e6.js' --source-map-root '/assets/locales' --source-map '/var/www/discourse/public/assets/locales/sr-53d537749608d7dfdfcd3a2581d2afb1dfa2447813239a81a56398a9e6b6e5e6.js.map' --source-map-url '/assets/locales/sr-53d537749608d7dfdfcd3a2581d2afb1dfa2447813239a81a56398a9e6b6e5e6.js.map'
gzip -f -c -9 /var/www/discourse/public/assets/locales/sr-53d537749608d7dfdfcd3a2581d2afb1dfa2447813239a81a56398a9e6b6e5e6.js > /var/www/discourse/public/assets/locales/sr-53d537749608d7dfdfcd3a2581d2afb1dfa2447813239a81a56398a9e6b6e5e6.js.gz

Compressing: application-925ac82337cd3f887f7ac5a86e5cb6081076cf526ae4d0c8ae77c2a8596f7aa7.js
uglifyjs '/var/www/discourse/public/assets/_application-925ac82337cd3f887f7ac5a86e5cb6081076cf526ae4d0c8ae77c2a8596f7aa7.js' -p relative -c -m -o '/var/www/discourse/public/assets/application-925ac82337cd3f887f7ac5a86e5cb6081076cf526ae4d0c8ae77c2a8596f7aa7.js' --source-map-root '/assets' --source-map '/var/www/discourse/public/assets/application-925ac82337cd3f887f7ac5a86e5cb6081076cf526ae4d0c8ae77c2a8596f7aa7.js.map' --source-map-url '/assets/application-925ac82337cd3f887f7ac5a86e5cb6081076cf526ae4d0c8ae77c2a8596f7aa7.js.map'

(Adam C. Engst) #2

OK, I guess Reset Upgrade may not be what I should do. Suggestions about how to get past this stuck upgrade?

20%20AM


(Denis Heraud) #3

Have you tried running ./launcher app rebuild in a terminal?


(Adam C. Engst) #4

No, since I’ve only dealt with Discourse at the interface level so far and would have to get my developer to do that. If that’s the fix, I’ll get him do that.

Also, I just wanted to make sure the developers knew that the install was failing, since it might be indicative of some bug. I have the log of the install so far saved out.


(Denis Heraud) #5

Ya, it sounds like there isn’t much more you can do through the admin interface.


(Adam C. Engst) #6

And indeed updating through the command line worked fine. So the devs should just consider this an anecdotal bug report with the beta8 installer.


(Régis Hanol) #7

I don’t see a bug here. Asset bundling is the most CPU intensive step in the upgrade process. Depending on your CPU it can take a couple of hours to finish…


(Adam C. Engst) #8

It never progressed from the point where it stopped, despite running for 4 more hours. Which seems wrong.