Blank page after upgrade due to broken plugin


(Karthik K) #1

I run my community at discourse.skcript.com. Yesterday, I upgraded the platform using ./launcher rebuild app. After the upgraded completed, users who try to access the platform without logging in are getting a blank page.

The app.yml is set to test-passed by default. When I change it to the stable channel, this is the error I get:

FAILED
--------------------
Pups::ExecError: cd /var/www/discourse && su discourse -c 'bundle exec rake db:migrate' failed with return #<Process::Status: pid 11533 exit 1>
Location of failure: /pups/lib/pups/exec_command.rb:108:in `spawn'
exec failed with the params {"cd"=>"$home", "hook"=>"bundle_exec", "cmd"=>["su discourse -c 'bundle install --deployment --verbose --without test --without development'", "su discourse -c 'bundle exec rake db:migrate'", "su discourse -c 'bundle exec rake assets:precompile'"]}
78b52f8ae680a31781647884748760b39c844756e8097fa3e7c3a4b0c8002c90
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one

Can someone please help me with this?


(Jeff Atwood) #2

You can’t downgrade from tests-passed to stable; it doesn’t work because your DB has changed.

Disable all third party plugins and rebuild.


(Karthik K) #3

Thanks for the info Jeff. Let me try that right away.


(Daniela) #4

If you are using the guest gate plugin then disable it, it’s broken and give you a blank page.


(Karthik K) #5

That was exactly the issue. Disabled it and it works now. :slight_smile:


(Jay Pfaffman) #6

See this: Guest Gate (Sign Up Popup Plugin) Or, better, Content Lockers - using pop-ups


(Joshua Rosenfeld) #7

This topic was automatically closed after 4 hours. New replies are no longer allowed.