Chrome: Section d-splash makes page static. Removing section id makes it working again

image

Seems like a bug specific for some configurations of Chrome.

It is on different pages. Removing profile helps for a day. Clearing cache etc does nothing good for it.

What do you mean by “static”?

Moving to support since there are no clear reproduction steps.

2 Likes

Static means - static. LITERALLY.

Steps of replication. Open Discourse.
Steps of avoidance: Remove entire <section id…

Just tried opening Discourse here on my phone and this site isn’t static, I could even type this reply just fine. :grin:

Can you provide a little more detail on the reproduction steps? Like what browser, browser version, OS, OS version and URL trigger this issue.

PC:
Chrome is up to date

Version 109.0.5414.120 (Official Build) (64-bit)
image

I’ve got latest Chrome open on Windows 11, and it’s working for me. Do you have any browser extensions that could be having an effect?

It is possible, that this is problem, because after resetting profile it behaves different.

It seems that bitwarden plugin / or youtube autoquality is not compatible with discourse.

1 Like

I’m having the same issue (for months now). Discourse pages just don’t respond on scrolling or keyboard (basically unworkable if you can only read the top of a thread). It has to do with interference with a Chrome extension probably as it doesn’t occur on other browsers or Chrome Canary (which doesn’t have any extensions). Indeed removing the <section id="splash"> element from the DOM with devtools makes it work. When I inspect in working browsers, that section element is not there upon loading, so there may be something keeping it in the DOM in my default Chrome. However I have removed my Bitwarden extension and the problem is still there (don’t have the Youtube autoquality plugin).

Any advise on how to find the culprit is welcome.

Probably not relevant but working on Mac OS.

Remove one extension at time until it works again and you will find the culprit.

You sure there’s no better way to dig into this using devtools? Not really keen to go and possibly delete over 30 extensions to maybe not even find the solution there.

For now I’m using a Tampermonkey script to just ditch the DOM element entirely but that’s just a workaround obviously.

Unless there is a DevTools console error log that you can use, I don’t see how.

You can use an incognito session, and toggle “Allow in Incognito” for one extension at time until it’s working. Wouldn’t take over 10 minutes.

Thanks for the suggestion. For some reason it’s gone now and I still don’t know which extension it was. Removed one extension at some point that was already disabled but don’t remember which it was, so it may have been that one.

Even re-installed Bitwarden to make sure it wasn’t that one after all.