Comments are not showing after post content

Thanks for checking. I think I see the problem. I will try something and get back to you about it.

Edit: this is what I think is happening:

Your posts are all being displayed on the WordPress posts page. By default, WordPress does not show any comments on this page. When you disabled all plugins and tried WP Discourse with the 2016 theme, no comments would have been displayed on your posts page because that is the default WordPress behaviour.

With the WordPress twentysixteen or twentyseventeen theme, to get comments to display on the posts page you need to add a line similar to this to the content.php file. This goes below the call to the_content():

global $withcomments;
$withcomments = 1;
comments_template();

When I do that, I am able to get WP Discourse comments to display on the posts page.

Are there any single post pages on your website that you could check? It would be good to see if Discourse comments will appear on a single page.

1 Like

there was already comments_template() function in content.php and i can see standart wordpress comments under the posts (as i said before), tried as single post, still nothing(

Can you see Discourse comments for single posts when you use the twentysixteen theme and disable all plugins except for WP Discourse?

1 Like

no( Wordpress sees that that there are comments http://joxi.ru/D2PJ9a4tdL5OXr 1 (with twentysixteen and Discourse enabled / with my current theme and all plugins enabled) but refuses to show them on frontend . Really have no idea what may cause this.

we managed to fix this)) There was an error in child-theme code and now it’s working fine) Thank you, Simon for your help and time)

1 Like

Comment box is not appearing on my blogpost. I am using twenty seventeen theme. Please somebody help me, I have been trying a lot of things since a week now.

Can you check that comments are enabled for the post? Also make sure that the ‘Enable Discourse Comments’ setting is enabled. That setting should look like this:

Let me know if comments are still not being displayed for you.

3 Likes

Hello! I am having the same issue. I have checked the posting and commenting settings and all seem to be checked correctly, but I am still not able to see the Discourse section at the end of the post. All I am seeing is the wordpress comment section. Previously, when my site was in staging, I was able to see the “Continue the conversation on Discourse” with a link. Any help is appreciated!

Hey Tim, could you just confirm a few things for me about your production site. If you could just check them off for me in your response. Thanks :slight_smile:

  • your WP Discourse plugin is connected to your Discourse, i.e. you see “You’re Connected to Discourse” when you load the WP Discourse admin panel;

  • your wordpress posts are being posted to your Discourse, and there are replies to the Discourse topic on the Wordpress post you’re not seeing Discourse comments on;

  • you have “Enable Discourse Comments” set to true and “Display comments for all topics” checked; and

  • your wordpress cache is not preventing you from seeing the comments. To check this, please try toggling the WP Discoursse “Commenting” setting “Clear Cached Comment HTML”.

1 Like

Thanks for the follow-up! All four checks down the board. Still, nothing is showing.

Ok, if you feel comfortable with it, could you go to the Logs panel in the WP Discourse plugin, download the logs and send them to me via PM? Note that there is no personally identifying information or secrets in the logs.

For more on the logs and what’s in them see

Sure thing. Will send them over. Where should I send them to?

Send me them in a message here on meta.discourse.org.

Click this link to compose a message to me.

It’s not allowing me to send you a message.

You need trust level 1 to send messages.

2 Likes

Angus, it will not let me send you DM’s or files due to my trust level. Is there an email I can send it to?

It will take you less than 10 minutes to reach level 1.

2 Likes

@uxdillux Thanks for sending them.

I notice you have the setting Cache Comment HTML enabled. Please disable this and also check Clear Cached Comment HTML at the same time (to clear any existing cache). Then load a wordpress post in an incognitio window and see if the comments load.

If that doesn’t work, please try enabling Load Comments With Ajax.

@angus I’ve completed the steps you listed and the comments are still not showing. Could it be a setting within the forum itself? When we were testing this platform, at the bottom of the post it would say “Continue this conversation on discourse” or something similar, and it would link to our forum. I am no longer seeing this after I publish a post to our forum.

If you’ve completed all of these steps, and you’ve completed all of the other steps I listed above, and comments are still not showing, the issue is not being caused by the WP Discourse plugin.

Have you changed your theme or other plugins recently?

1 Like