Comments not appearing and posts unlisted

Hi,

The discourse comments are not showing up (even just the link to the forum) and the posts created on the forum are unlisted. I have tried going to the theme template and replacing the WP comments block with a Discourse Comments block but it doesn’t render anything.

2 Likes

Well, after tweaking some settings it’s appeared to start working. Not sure what i changed but I am specifying the Discourse Comments in my theme template instead of the default comments.

2 Likes

For us worked when we unchecked

embed unlisted: Embedded topics will be unlisted until a user replies.

I have that parameter unchecked:


And yet it still doesn’t work as new posts are unlisted.

The way this works was recently changed. You need to disable the embed unlisted setting on Discourse:

The WP Discourse plugin’s “Publish as Unlisted Topics” option no longer has any effect. @angus, if it hasn’t been done already, that option should be removed from the plugin.

5 Likes

Yes, please check the site setting embed unlisted as Simon mentions.

The plugin’s option has the same effect as before, i.e. to unlist embedded topics from the WP Discourse plugin. The change is that the site setting in Discourse is now applied consistently across different embedding scenarios, including WP Discourse. There may be a use case for un-listing embedded WP Discourse topics using the option in the plugin and listing embedded topics from other sources, so I don’t think it makes sense to remove the option at this stage.

1 Like

I’ve also noticed that sometimes when I create a post on Wordpress it will create the Dicourse topic (listed after changing that Discourse setting) but it won’t link the topic on Wordpress. So I have to go to Wordpress and manually link the blog post to the Discourse post.

Any idea why that may be happening?

Hey @hunterboerner, yes that’s a different issue.

If you can reproduce it reliably, or have a demonstration or some logs, please post a new topic in wordpress and I’ll help you out :+1: