Configuring email SMTP settings just isn't working


(Frank Bailey) #1

Hi folks. I try not to post unless I’m really, truly stuck. I’ve installed Discourse as a Docker container in Ubuntu 16.04 which is a guest VM in VirtualBox with a Windows 10 host. The installation was successful, however I cannot for the life of me manage to configure the SMTP settings in such a way as to allow me to actually receive the activation email.

I’ve tried using a small free SMTP server for development called MailSlurper on the Win10 host, which didn’t work. I tried another similar tool called Papercut, which also didn’t work.

I’ve set up port forwarding from a free DNS service hostname for MYFREEHOST.ddns.net on ports 25 and 2500 (the MailSlurper and Papercut ports), neither of which worked. I can Telnet from the Ubuntu guest OS into the two programs without incident, however sending emails through from Discourse just doesn’t work.

I have also tried using Gmail as the SMTP host using Blaise Pabon’s advice here:


Since my email address is a gmail one it seemed like that might do the trick, but alas not.

I also signed up for a free Mailgun account and tested with that, rebuilding the app after each change to the SMTP settings, and still it does not work.

Can anyone possibly offer any suggestions or advice, or mention the no doubt blindingly obvious thing that I should have checked, please?


(Bhanu Sharma) #2

Mailgun should Work Recheck Your app.yml if You’ve left the port or some other thing?

have You checked Your SPAM folder?


(Jay Pfaffman) #3

Make sure that you have activated the domain on Mailgun and that you don’t have any errors on your console there.