Direct message draft is lost when page is refreshed

I just lost a direct message I spent 2 hours writing because the page refreshed and the draft was lost. I don’t think this happens with topics (I just tested it and it didn’t), but it’s happened to me more than once with messages.

On iPhone, I accidentally refresh the page because I try to scroll up while previewing my message and that gesture refreshes the page. Try it to see what I mean.


Are you using the Discourse Hub app? Does this happen in Mobile Safari?

1 Like

I’m using Chrome for iPhone. I just tried it on mobile Safari and it doesn’t appear that Safari has the same page refresh gesture.

Also, on mobile Safari, Discourse appears to save message drafts! :open_mouth:


What version of Discourse are you on? I fixed a lot of issues with drafts over the past few weeks. I highly recommend upgrading to latest.

Can you update to latest and reproduce this issue?


I was already on the latest when the issue occurred: 2.4.0.beta6

I was just able to reproduce the issue. Strangely, message drafts saved in one message thread I tested but not in the thread where I originally had the problem. Hm.

1 Like

What are the steps? Can you repro on meta? Are you 100% sure this is not in your drafts section in your profile?


Yes, it isn’t in my drafts. I just checked.

Oddly, I was able to reproduce the issue earlier but now the draft saves successly (in the same message thread where I reproduced it). :confused:

I can’t discern what might be causing the draft to save sometimes and not other times. As far as I can tell, I’m doing exactly the same thing: tapping my profile picture, tapping the mail icon, tapping the title of a message thread, scrolling to the bottom of the thread, hitting reply, typing something, and then refreshing the page.

If it helps at all, this is my Discourse.

It helps tons, your last commit is Friday October 11, that is prior to my draft fixes. You got to update to latest tests-passed and see if there is any way you can swing this error.

For the record I was able to reproduce all sorts of very quirky draft things prior to my last round of fixes.


My admin dashboard tells me I’m running the latest version. How do I update?

Edit: Found the answer here:


Which iPhone do you have and which version of iOS are you running on it? The latest version of iOS (13.2) has had RAM management issues.

That’d be my best guess. Either way, I wish you luck! :crossed_fingers:

1 Like

The draft inconsistencies had nothing to do with device or web instability. There were rare cases in which the system used to say “draft saved” and a draft was not saved, this is now fixed.


It’s good to hear that the problem was fixed! Thank you for informing me. :+1:

1 Like

Okay, glad to hear the issue I reported had already been solved. I just needed to upgrade to the latest version.

Thanks for all your help. Much appreciated.