Discourse Sitemap Plugin

Those without a Google account can notify them of changes with:

curl http://www.google.com/ping?sitemap=/path/to/sitemap.xml

Here’s a rake task to notify a few different services simultaneously: made-mistakes/Rakefile.rb at master · mmistakes/made-mistakes · GitHub

1 Like

Is sitemap a necessary evil? If i don’t use this plugin, will my community not get the exposure it seeks?

I don’t think so.

https://meta.discourse.org/t/sitemap-xml-for-google-webmaster/9054/9?u=vinothkannans

6 Likes

My understanding is that if you have migrated a large site, it might help. If you are starting a new community, then it’s not necessary.

3 Likes

Everyday gives an Errorlog, is it time to take a look at it now? Control card is incorrect

Is this the sitemap plugin that is official now by this commit?

1 Like

Yeah we need to discuss this with @RGJ, we have an official fork now that is quite a few commits ahead of the OP, it is probably best if we take over the repo to avoid confusion

6 Likes

I’ll install this once your repo is out.
Many Thanks!

Yes, that is ok with me. I seem unable to transfer the repo since you have a fork with the same name though, and I would prefer to have the old repository location redirect to the new/official one. Do you have any ideas how to approach this?

3 Likes

Feel free to transfer it to SamSaffron and then I can do all the shuffling needed.

6 Likes

Hi, what could be the reason I get error 502 bad gateway on my sitemap?
https://forum.dobreprogramy.pl/sitemap.xml

no 502 error! works perfect for me?!

4 Likes

If possible, I would like to hear people’s experience of using this plugin. Is it stable? any errors/warnings? Was the issue from 2016 solved?

Really looking for feedback on this plugin.
Thank you :slight_smile:

2 Likes

We use this plugin on our business tier, it works fine, not aware of any open issues.

5 Likes

This plugin is giving me invalid URL’s in the sitemap.xml. E.g the site uses “https://www.domain.com” pattern for the URL, however, the sitemap contains “https://domain.com” pattern which is wrong. I couldn’t find settings for the domain, can anyone suggest?

Look in app.yml. That is where the hostname is set.

1 Like

I have changed “domain.com” to “www.domain.com” in the app.yml of hostname attribute and finally rebuild it again, but in the sitemap, it’s still the same i.e. “https://domain.com…”. I also re-enabled the Sitemap but no effect.

Hi, sorry for my bad english. I set up links https://example.com/sitemap.xml in Google and Yandex search engines. But they cannot index them because of the underscore in the file names. Can this be fixed?
Screenshot

Why would underscores be a problem? They’re not.
Even the sitemap index example at the protocol specification website uses underscores.

Note: A Sitemap index file can only specify Sitemaps that are found on the same site as the Sitemap index file. For example, http://www.yoursite.com/sitemap_index.xml can include Sitemaps on http://www.yoursite.com but not on http://www.example.com or http://yourhost.yoursite.com. As with Sitemaps, your Sitemap index file must be UTF-8 encoded.

2 Likes

Sitemap line in robots.txt renders incorrectly. You can check it on https://meta.discourse.org/robots.txt. Watch the last line.

<%- if SiteSetting.sitemap_enabled? %>
<%- unless SiteSetting.login_required? %>
Sitemap: <%= request.protocol %><%= request.host_with_port %>/sitemap.xml
<% end %>
<% end %>
4 Likes