Dragging highlighted texts causes Chrome freeze


  1. Highlight some texts (e.g. by double clicking on a word)
  2. Click and hold on the highlighted texts, start dragging
  3. After dragging any arbitrary distance (could be as short as one pixel) on the same page, release the mouse button, observe browser freezes and not responding to mouse clicks.

Another post suggested “to use an SSL certificate”, and I wonder if he can elaborate.

Related: Drag'n drop cause crash browser tab - #3 by MrIgareshka

OS: Fedora 40
Chrome ver.: 124
KDE Plasma Version: 6.0.4
Kernel Version: 6.8.9-300.fc40.x86_64 (64-bit)

Is this happening on a site which is not using https? That seems to have been the case in that other situation.

1 Like

I see, so “using an SSL certificate” means using https, correct me if I’m wrong. In my browser tho the “Always use secure connections” option is already toggled to On. Whereas the “Manage certificates” section is empty, if it’s normal … ?

To answer your question, I experienced this issue on both http and https sites.

Try adding your domain in the chrome browser

restart the browser and try again.
If the problem is gone, then SSL is needed

Don’t forget to give permissions on the site (where clipboard, microphone, geolocation, etc. are allowed)

1 Like

Thanks for the suggestion. Funny thing is the offending domain is chrome://flags, which can’t be added into the #unsafe-treat-insecure-origin-as-secure list (i.e. list entry doesn’t persist after restarting).

By default my browser allows all sites to ask to see my clipboard, and I never added any site to denylist. I tried again here to add the domain into the allowlist, but errored out for invalidity.

Edit: I’ll update as I try other sites

It’s strange that you can’t add a domain to the flags.

Does this problem only occur on Linux? Have you tried using Windows and other browsers? And have you tried running the forum in safe mode?

What do you mean? The chrome pages themselves should never cause issues.

1 Like

The flag might accept certain protocols only. And chrome://flags prolly is not one of them.

I haven’t tried other OS. My guess is Wayland+NVIDIA, which tend to cause various issues.

I can test your site if you want. Send me a link to your forum in private messages.

Thanks for offering help. I don’t see the PM function (maybe my account is too new?).

And unfortunately the issue is not reproducible at the moment - some of the tweaking on my Linux in the meantime may have worked around it (temporarily), which is a very Linux-y thing…

1 Like