E-mail notifications when members are mentioned

Feels like a silly question, but I can’t find the setting for this - and the last posts were from a few years ago.

How do I make sure members get an email notification when they are are @mentioned within the community? (or even group @mentioned).

At the moment it’s not happening.

1 Like

This is set on the Emails section of the users preferences page. The default setting is to send an email to a user if someone quotes them, replies to their post, mentions their username, or invites them to a topic when the user is away from the forum:

If you are finding that users are not being sent emails for this, have a look at your default email level site setting. The default value of that setting is “only when away.” Make sure that it isn’t set to “never.” You can adjust the email settings of all users on your site by making changes to your default email level site setting and selecting the option to apply the changes historically.

2 Likes

Thanks @simon - still struggling with this a little though.

This is the current setting I can see:

However, when I @mention someone, they don’t seem to be getting an email notification.

What specifically do I need to change here?

1 Like

I am not seeing any settings in your screenshot that would prevent emails from being sent when a user is mentioned. You can confirm whether or not emails are being sent when users are mentioned by going to your site’s Admin / Emails / Sent page and entering mentioned into the Email Type filter input. The screenshot below is from my test site:

If the issue is happening on a site that we host, we’ll login and have a look at what’s going on.

4 Likes

@biologist maybe this is the same problem you had?

1 Like

@Moin Sorry, totally forgot to answer.
No, this isn’t the problem I had. In my case I had to restart docker in order to get dns-resolution back. Was not associated to Discourse. But anyway, I don’t know why that happened.

1 Like

@Richard_Millington

I see you have the disable mailing list mode box checked (Disallow users from enabling mailing list mode (prevents any mailing list emails from being sent.)

Try unchecking that box and see if the emails get sent.