ERR_BLOCKED_BY_CLIENT from AdBlock plugin


(Pugwash) #1

Here’s the post in question

Whenever I attempt to edit the subject or the body, I get a modal error message:

Sorry, an error has occurred.

When I inspect the network activity in Chrome (Version 45.0.2454.101 m) I see the following:

The error is isolated only to this page, all other pages work fine. I believe @zogstrip and @techAPJ have admin access our Discourse instance, if you want to reproduce.

Thanks!

EDIT:

Tested in IE 11 and it works fine, just not in Chrome.


(Jeff Atwood) #2

Hmm @techapj can you try to repro?


(Arpit Jalan) #3

I can’t repro it on my MacBook Pro (OS X Yosemite) Chrome Version 45.0.2454.101 (64-bit).


(Pugwash) #4

Thanks for taking a look!

Here’s what I’m seeing:

  • I’m using Windows 8, Chrome 45.0.2454.101 m
  • Also had the same issue on my home machine which is Windows 10 (Chrome… not sure which version?).

(Jeff Atwood) #5

Are you sure there is not anti virus or upstream proxies interfering with the request? Are you using any Chrome plugins, have you tried in Chrome safe mode with all plugins disabled?

Blocked by client usually means something in your box (or browser) is interfering.


(Pugwash) #6

You’re absolutely right. I disabled AdBlock (2.41.2) and it worked!

I’m not 100% sure how AdBlock works, although given that the topic of this post is about Advertising that would make sense.

Thanks!

EDIT:

I replicated this in try.discourse by creating a post with the word “advertising” in the subject. Initial post creation is fine but future saves initiate a post back to the friendly URL Discourse creates (http://try.discourse.org/t/advertising-test/329). I think AdBlock simply works on the basis of inspecting and blocking HTTP calls, so there’s a rule there that will block XHR calls if the word “advertising” is found in the URL.

Not really a Discourse issue but it may be useful for anyone else encountering the same behaviour.