Errors with Reactions After Upgrade

After upgrading to 3.3.0.beta1-dev, the plugin stopped working. And when enabled, forum stops loading.
Is there something that I need to do?
Thank you.

1 Like

Could you check your /logs and browser console for more detail on what might be happening?

Sadly I am not qualified enough to comment on logs but I couldn’t see any warnings about Reactions.
Hope this is helpful.

Hmm. :thinking: I’m not seeing any issues with them here on meta so we will need some extra info to help you out.

On the off-chance, I don’t suppose you have Retort installed instead? That had to have an update earlier today to fix an error.

No I don’t @JammyDodger.
Everything was fine until I updated and afterwords I rebuilt.
Maybe I should try reinstalling.

If you can have a look in your browser console when you encounter an error that could provide some extra information.

Or if you can share a link to your site, we could have a look and see if we can see anything?

Thank you very much in advance.
Here’s the address of my forum:

There’s one error in console:

Uncaught (in promise) Error: Could not find module `discourse/widgets/default-notification-item` imported from `discourse/plugins/discourse-reactions/discourse/widgets/discourse-reactions-reaction-notification-item`
    at loader.js:247:1
    at l (loader.js:258:1)
    at s.findDeps (loader.js:168:1)
    at l (loader.js:262:1)
    at requireModule (loader.js:24:1)
    at auto-load-modules.js:26:7
    at Array.forEach (<anonymous>)
    at c (auto-load-modules.js:20:34)
    at Object.initialize (auto-load-modules.js:50:5)
    at index.js:145:1
    at e.each (dag-map.js:191:1)
    at e.walk (dag-map.js:120:1)
    at e.each (dag-map.js:66:1)
    at e.topsort (dag-map.js:72:1)
    at e._runInitializer (index.js:158:1)
    at e.runInstanceInitializers (index.js:143:1)
    at u._bootSync (instance.js:86:1)
    at e.didBecomeReady (index.js:602:1)
    at invoke (backburner.js.js:280:1)
    at h.flush (backburner.js.js:197:1)
    at p.flush (backburner.js.js:358:1)
    at B._end (backburner.js.js:798:1)
    at B._boundAutorunEnd (backburner.js.js:523:1)

I think you’re using an old plugin version.

widgets/default-notification-item has been removed from core recently in #24906.
widgets/discourse-reactions-reaction-notification-item has been removed from the plugin last year in #262.

Is there an update available?


Thank you very much for your support but it seems to me that I am using the right plugin:

Am I not?

And one more thing, auto backup does not work either. :slight_smile:

Could you try a rebuild from command line? Were you by chance only updating discourse and not the other plugins on admin/upgrade?

1 Like

I’ve tried to update from admin panel and I am going to try rebuilding second time.

Nope, rebuilding didn’t work either.

That’s odd. :thinking:
In Admin → Installed plugins, can you show the exact version of this plugin?



This is the version.

And backups does not work as well.

Yes, the plugin is not updated. :thinking:

If you say upgrading from the panel or console doesn’t change anything, I’m unsure what we’re missing.

When you rebuild Discourse, the GitHub repository is cloned and should pull the latest compatible version. Here, you’re using the latest Discourse version; no pinned version in the plugin is available. I would expect to see the latest plugin version.

I would be curious to see the rebuild log.


Hello :wave: Maybe git pull can help? :thinking:

cd /var/discourse
git pull
./launcher rebuild app

I am trying to rebuild after git pull command but it fails.
I have no idea what the problem is.
Tried discourse-doctor, ./launcher cleaner
And trying another rebuild but it is so slow and I think it’s a memory issue but I am totally lost.
Node.js heap_size_limit is less than 2048 MB, setting --max_old_space_size=2048 is where it stops.
And most horrifyingly, I might be out of beer and there’ll be several people trying to kill me tomorrow.

What is the error message? And is git or the rebuild failing?