Firefox on FreeBSD gives me the mobile site

I have a FreeBSD desktop. When I visit (or with firefox, it gives me the mobile site. If I use chrome I get the desktop site.

Looks like my user agent is:

Mozilla/5.0 (X11; FreeBSD amd64; rv:95.0) Gecko/20100101 Firefox/95.0

1 Like

I can’t reproduce this on Firefox Linux using that User Agent. Tried on Meta and

I was forcing a 1920x1080 resolution device and using the provided UA string. Anything else that you think may be triggering the bug?

A couple of a days ago, I managed to finally get around to installing FreeBSD in a virtual machine and tried reproducing this issue using the same user agent, but to no avail. Even after using the same user agent, it was loading the desktop website.

I think this might be an issue with an older version of Mozilla Firefox. I’m running the latest version (96.0.3), which might’ve fixed the issue altogether, so try updating to that in the meantime. I’ll try installing an older version (95.0) to determine this issue once and for all. Just give me a couple of hours.

The -CURRENT version of the FreeBSD firefox port is 97.0, that’s what I’m using today; I’m still getting the mobile site.

Mozilla/5.0 (X11; FreeBSD amd64; rv:97.0) Gecko/20100101 Firefox/97.0