How to disable "Body seems unclear, is it a complete sentence?" checker


(Jason Sachs) #1

I’m an admin of our Discourse server, and I’m in a small group of coworkers of the “We’re all reasonable adults here” sort.

How can I disable the “Body seems unclear, is it a complete sentence?” checker? I don’t need an automated program to prevent someone from posting something, even if it looks to the Discourse software like an incomplete sentence.


How to disable "Title seems unclear, is it a complete sentence?" checker
(Christoph) #2

Try setting body min entropy = 0


Turn off "Title seems unclear, is it a complete sentence?"
(Jason Sachs) #3

Thanks, that worked.

It would be really nice to have a more meaningful error message. (otherwise my gut response is "No, you stupid bastard server, I don’t care, this is what I wanted to post! So #@$@#% off!)

It would also be nice to be able to configure it so that it was just a warning that appeared once, and if you really wanted to post, then you could click “No, I really mean it!” and post your content anyway.


(Rafael dos Santos Silva) #4

Are posts with less than 7 characters that common in your instance?

The idea of the message is to have the user put more thought on the post, and use enough information to keep the discourse flowing.

Of course the admin of the board can change the settings if he wants to.


(Jason Sachs) #5

Look, this is a technical bulletin board in my case, and when we say “x[n] = x[n] + x[n] - y[n]” (or whatever) we mean it. We don’t need a computer blocking us from posting.

I don’t mind the default behavior – although it is annoying… I just wish it were a little more flexible and obvious. The existing behavior has all the charm and helpfulness of an IQ 80 security guard.


(Jiyin Yiyong) #6

body min entropy = 0 in app.yaml?


(Christoph) #7

No, in admin/site_settings


#8

Sorry to necro this thread, but I think context is important. I am posting a complete sentence of three words (total ten characters) and valid punctuation and this error is coming up. I tried setting as above. No joy. It’s very frustrating as an admin to be unable to post a perfectly legitimate sentence that meets all configured limits we have set.


(Jeff Atwood) #9

Then change the setting, what’s stopping you from doing so?


#10

As I mentioned, I tried changing the setting, as above. No joy.

I’ve worked out what it was though.


(Joshua Rosenfeld) #11

Mind sharing what the issue was? Did you have to adjust a different setting? Did you change your sentence?


(Jason Sachs) #12

No joy.
He was sad.
So he tried hard to fix.
He found something at ten
And then set it to six.

But that was no good!
Oh, what could he do?
He took what was six
And set it to two!

But two was too small,
There were those that would say.
You could say NO.
And HA. And UM. And OK.

What to do? What to do?
So he went back again
And set what was two
Back to six,
Then to ten.

No joy.
Then he said,
Before going away,
There are so many things
That are too small to say!


(sorry, just got done reading The Cat in the Hat to a toddler)


#13

Oh yes, sorry! I was posting all in caps. I have “shouting” disabled :slight_smile:

@jmsachs Fabulous!


(Leo) #14

I’ve set body_min_entropy to 0. but can’t get through this check Body seems unclear, ....
The post body is mix of different language, like the text below

ABC このテキストは日本語です. このテキストは日本語です

It works if text is only in japanese letters. but won’t work if there is any english alphabets involved.


(honggian) #15

I have a same problem, if there any solve this problem, please let us know.

Blockquote
It works if text is only in japanese letters. but won’t work if there is any english alphabets involved.

In my case, it it Korean + English combination.


(Stephen Chung) #16

There are a whole bunch of English-oriented settings that you need to turn off if you use anything other than English. Search meta for them.

In your case, look into:

allow uppercase posts, title prettify, title max word length