I just ugraded to the latest version and now the admin console is blank


(Dean Peterson) #1

I went from, I believe, version 1.14.beta1 to 1.14.beta3


(Jeff Atwood) #2

I don’t think your upgrade succeeded. Is this a Docker based install? How much RAM and disk space?

Try upgrading from the command line with our SSH 3-liner.


(Dean Peterson) #3

Wow, thanks for replying personally Jeff! I am running a Docker based install. It is on a dedicated Redhat Enterprise Linux machine with 8 gigs of ram, two xeon sockets and a terabyte hard drive. Most of that is given to Discourse.

I have run the update from the Dashboard in a previous version and it worked great. I ran this time and everything appeared to run smoothly again. It gave me a message it ran successfully and told me to wait 30 seconds before refreshing.

Is the SSH 3-liner in the document on Github? I do not see mention of it here: discourse/INSTALL-cloud.md at master · discourse/discourse · GitHub


(Dean Peterson) #4

I just visited /admin/upgrade and ran the update process again. Everything is up to date and back to normal so you helped by sending me to the docs on Github. When upgrading this time it did say everything was already compressed; some things must have taken effect when I tried to upgrade last night. Running the process again must have finished the process. Thanks for your help! It is running great again.


(Wes Osborn) #5

It took awhile for the dashboard to populate for me on our last upgrade too. I’m guessing it was taking time to build some of the cool new stats. It probably took 15+ minutes before anything was populated. Though the other areas of the Admin: Settings, Users, etc. all worked immediately after the upgrade.


(Régis Hanol) #6

If you don’t want to wait for the stats to populate, you can go to your.discourse/sidekiq/scheduler and trigger the “Jobs::DashboardStats” job :wink:


(Régis Hanol) #7