In Firefox mobile, Inline tag search/filter only triggered with space character

I have just changed to an Android smartphone (from Windows) and noticed this bug.
I use Firefox (initially for its user scripts capability).

When I type text in inline tag search, the results are always top tags rather than the search result.

I could not reach test.discourse.org yet to try and reproduce here.

Trying to find a digital something tag, it is not found:

Although it does exist: Topics tagged digital-media

Oh in fact I have to add a space character to trigger the search.
Is it normal?
I don’t remember doing that on desktop Vivaldi nor on Windows Phone Edge.

Can we repro this with tags enabled @tshenry?

P.s. congrats for getting away from Windows Phone :calling:

6 Likes

Hmm, I have a suspicion about what’s going on here.

@jesus2099, can you tell me what happens if you fully spell out the digital-media tag in the tag chooser’s search field? I have a feeling the tag is restricted to the MusicBrainz and Style categories and you are trying to apply it to a different category. This would explain why it isn’t showing up when you start typing out the name of the tag.

The only way I can repro the search behavior you describe when trying on Meta is if I’m searching for a restricted tag outside of the category it’s restricted to.

On iOS Safari, I’m not finding I need to add a space to trigger a search in the tag chooser. If you are referring to the overall site search, there are certain circumstances on desktop where that can happen. Particularly, if you have closed the search dropdown when it had an existing search term in it, then opened it back up.

4 Likes

When I fully type, it proposes me to create that tag, still no search without space bar.
I don’t think the tag is restricted because on desktop Vivaldi here, I can type digi and see digital-media, already popping up in the inline search.

When I say inline search, I mean the little tags field when you create or edit a post.

1 Like

I don’t have an Android phone to use for testing, but I did try Firefox on iPhone and can’t reproduce the behavior with any of the the tags on my test site.

Meta has a nice assortment of tags. Can you check to see if you run into the issue here? If it’s limited to the one site, I’d try to reach out to the admins of the site to see if there’s some kind of customization that might be causing issues on mobile.

1 Like

I can reproduce this behavior in both current Firefox for Android (Fennec) and the next Firefox Preview (Fenix).

iOS doesn’t have any browsers besides Safari, as the others are just basically skins over the available Safari engines.

3 Likes

I tried on meta before opening this topic but it seems I don’t have enough rights to use tags in any topics, here.

1 Like

I have reproduced in try.discourse.org (I thought it was test in my OP but now I found out)!

The issue is that the input event followed by a small delay before launching search seems not triggered or caught:


I type cod for code tag and the filter search does not launch.


Now I press space bar and the filter search activates (I will later see that it would also launch with enter key).
Now drop down only show code (good).


I backspace cod, no updates (drop down show code only)


I type new for newbie, still no update (drop down still shows code).


I press enter key and now drop down is updated again.

2 Likes