Latest update gives blank screen on mobile

A few minutes ago I updated my mostly vanilla site and find that the mobile version shows a blank screen on login (Firefox). You have to scroll a page to see the normal latest topics list. Desktop is ok.

The header section is there (logo, search, hamburger, avatar). Then nada for a screen’s worth.

Which build version are you currently running?

Is the site ok in safe mode?



( 843907d1ac )

Haven’t run safe mode yet

Previous build running aok was ~10 commits before this iirc

Same issue. As I mentioned, the site is almost 100% vanilla

843907d1ac is working for me, Firefox mobile view and iOS are both ok.
Can you post or PM a URL of your site?

I’ll send a login by PM. Just checked Brave, same issue. I see the page load normally for a fraction of a second, then it disappears. Android fwiw. Just speculating, but it seems that something blank loads ms after the normal page loads.

Almost? :blush:

I’d be interested to hear the results of a safe mode test as it could be that 1% that’s causing an issue, a plug-in, etc.

1 Like

^ I mentioned I tried safe mode. Yes, vanilla bar docker manager plugin. No theme.

Another user reports it’s blank using iOS and the Discourse app

It’s not setting the sidebar width to 0 (done in this commit, which is included in your build)

Your mobile stylesheet is much older as your build. I don’t know what could be causing this.
Did you rebuild from the command line?


Rebuilds are always through the admin/upgrade link. Command line is only invoked when docker manager requires an upgrade through it.

I don’t think it’s a client side caching issue as I used Brave (mobile) on the site for the first time just now.

Sorry, I guess I didn’t read past this part of your post :blush:

1 Like

Well, I recommend trying the command line upgrade rebuild.

Exactly, and I have never even visited your site before today either. So something on your server is deciding it should serve the old assets. This is remediated by nuking the container and rebuilding it from scratch.


Sure I can try that. I’m wondering why certain stylesheets are left untouched by the upgrade link. Seems odd :thinking:

That’s fixed it. But I’d think something awry is happening for the old stylesheet to persist like this between builds.


Absolutely, so maybe someone from the team with more knowledge about docker_manager and the asset pipeline can weigh in here?

1 Like

Can’t think of any reason for this off the top of my head - I’m not aware of any recent changes to the stylesheet compilation system. It’ll be tricky to work out the root cause now that things are working again. But if it happens again, please let us know!