Launcher rebuild app does nothing

Using PuTTy, and logging in to my Digital Ocean Droplet as root to add a Discourse plugin, following the standard directions here, then typing

./launcher rebuild app

results in cursor dropping down to next line in PuTTy console, but otherwise doing nothing

No error message or visible progress indicator of any kind. The Discourse installation is meanwhile still working and is showing no additional plugins, even after waiting half an hour.

I have tried exiting PuTTY and restarting, and reconnecting again to my Digital Ocean droplet, and repeated the exercise, with exactly the same non-result.

the relevant section (in its entirety) of containers/app.yml, after the new plugin was appended at the end is

- exec:
cd: $home/plugins
- git clone
- git clone
- git clone
- git clone

I can’t seem to spot any typos in the line I added at the bottom, so not sure if it is the contents of this file or something else.

As a test, I deleted the extra line I just added and resaved app.yml - but same result.

Has anyone encountered (and solved) this issue?

In answer to my own question - one workaround seems to be to log in to Digital Ocean and power cycle the droplet. The rebuild then occurs normally


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.