Login form missing entirely from Discourse instance

I’ve got a Discourse installation (Bitnami AMI on AWS) that has been dormant for a couple months… when I returned to it today, I noticed the login form appears to have disappeared.

I have no idea what has caused this as it was working just fine a while back and I was able to login by entering my username and password. It’s also worth mentioning that I’ve tried the admin-login and every known-good email address I try returns unknown.

Here’s a snippet of my site_settings.yml (just the login section): site_settings.yml-login-bitnami-nialls · GitHub

And a screenshot of the issue: Screenshot 2020-07-09 at 13.08.46

That’s not a supported installation method, and we regularly see issues caused by it. Please follow our official install guide

I would suggest trying safe mode, and looking in your browser console for errors.

4 Likes

Thanks for your reply, @david! Unfortunately safe mode didn’t help, I already tried that and the issue persisted, apologies for not including that point in my OP.

Fortunately it’s an installation with minimal “work-done” so I will likely kill it with fire and start over using your official install guide.

6 Likes