Port 443 of computer does not appear to be accessible using

I keep getting this error, every time I run ./discourse-setup Any solution? (I added a dns A record that points to my VM’s ip).

Checking your domain name . . .
WARNING: Port 443 of computer does not appear to be accessible using hostname:  forum.roblox-devs.com.
SUCCESS: A connection to port 80 succeeds!
This suggests that your DNS settings are correct,
but something is keeping traffic to port 443 from getting to your server.
Check your networking configuration to see that connections to port 443 are allowed.

The first thing to do is confirm that forum.roblox-devs.com resolves to the IP address of this server.
You usually do this at the same place you purchased the domain.

If you are sure that the IP address resolves correctly, it could be a firewall issue.
A web search for "open ports YOUR CLOUD SERVICE" might help.

This tool is designed only for the most standard installations. If you cannot resolve
the issue above, you will need to edit containers/app.yml yourself and then type

./launcher rebuild app

2 Likes

Hi. :wave: Why did you mark out the IP addresses in the screenshot? We can’t confirm if it ought to match your public DNS records:

$ dig forum.roblox-devs.com

; <<>> DiG 9.11.21-RedHat-9.11.21-1.fc32 <<>> forum.roblox-devs.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 12504
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 4, ADDITIONAL: 9

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;forum.roblox-devs.com.		IN	A

;; ANSWER SECTION:
forum.roblox-devs.com.	300	IN	A	51.103.133.217

Is that the correct IP address? Are you blocking port 443 with a firewall?

3 Likes

I’m sorry for the late reply,
Each time I run ./discourse-setup It shows me the following errors:
WARNING: Port 443 of computer does not appear to be accessible using hostname: forum.roblox-devs.com.
WARNING: Connection to http://forum.roblox-devs.com (port 80) also fails.
Is there any possible fix?

Apache is holding the ports, you should disable/remove it if you have no use for it.

I did stop apache service, Now it is giving me a similar error.

443 might be closed by a firewall :thinking: but I believe it’s just a warning at this point?

How can I check if the port is blocked by a firewall?

Assuming your host has ufw installed, with something like sudo ufw status verbose

Does that mean anything?

Here, I run sudo ufw status verbose
image

So I think you are good on this front.
Maybe now
./launcher rebuild app
Inside the discourse directory

I’m sorry I didn’t see this, do you already have an app running on this host?

Like another website? Nope.

It works now, but the subdomain isn’t working.
image

When I go to http://roblox-devs.com/ and http://forum.roblox-devs.com/ it works.

Try clearing your cache.

I did, it is not even working on phone.

Huh, but I can see the finished setup page…

EDIT: Try restarting your host and rebuilding the forum?

1 Like

Indeed, it works here too, but the https is still to be setup

1 Like

You seem to be using Cloudflare ?

Cloudflare? I don’t think so.