Upgrade page links to https://admin/upgrade


(Paolo G. Giarrusso) #1

Short version: on Discourse 1.4.3, the upgrade link now leads literally to the broken https://admin/upgrade (and I don’t have admin as a hostname), both with the previous and the current docker_manager (if that makes a difference). This worked before, so it’s confusing. Thankfully, it’s a minor issue because I can’t still use the correct URL https://FQDN/admin/upgrade.

My Discourse is behind reverse proxy, but I don’t see config changes there that are obviously at fault.
Latest change I did was to the container .yml config, adding tiny as init process to workaround the bug in the AUFS kernel module.

What I did:

I’m running Discourse 1.4, and upgraded until 1.4.3. When trying to upgrade to 1.4.4, the upgrade link is to https://admin/upgrade instead of https://FQDN/admin/upgrade— not good.

But the latter page still “works” — upgrading Discourse is disabled, so I tried upgrading Docker manager hoping it’d help. This seems intended and normal, though the GUI does not show this dependency perfectly so I didn’t know this would help — indeed, people do get stuck. But this is a minor (and orthogonal) usability issue, so I’ll shut up

After that, the upgrade link still leads to https://admin/upgrade, but the correct URL works fine and allows me to complete the upgrade.


(fearlessfrog) #2

Same issue for v1.4.4 upgrade. Broken link as shown by this beautiful red arrow:

Manually typing the full address works ok.


(Sam Saffron) #3

I am not seeing this happen on latest so as much as this sucks I got to close this, only way to fix it is upgrade your instance and we can not do that without you doing a manual upgrade

cd /var/discourse
./launcher rebuild app

(Sam Saffron) #4