User profile : Oops! That page doesn’t exist or is private

Hello dear friends . i dont want to take a lot of your time, but i need your help .
My Discourse have a litle errors , when im clicking in profile to user i receive this message : Oops! that page doesn’t exist or is private.


I dont now why all url /u/user/summary make me redirect to /404
Im not sure if this have another error in my system. all users cannot make login , because systen sayed : Unknown error .


Iam reading here on forum and i see have another like this problem .
But if its someone to help me for this errors ?
until yesterday everything went very well and im was ever regular with updates .
– I use docker pannel from Plesk and i used this installation method :

Thanks

2 Likes

I think I have exactly the same problem since months and nobody has been able to solve it. But check something which I noticed, the problem is only when you are logged in as admin. Normal user can see profile pages without the problem.

Can you replicate that scenario?

1 Like

@absi Thank you for your answers i read messages from @codinghorror in your post, and hi have right , i remove all plugins and now its working very well .
This is my plugin List

      - git clone https://github.com/discourse/discourse-whos-online.git
      - git clone https://github.com/discourse/discourse-spoiler-alert.git
      - git clone https://github.com/discoursehosting/discourse-guest-gate.git
      - git clone https://github.com/discourse/discourse-voting.git
      - git clone https://github.com/discourse/discourse-solved.git
      - git clone https://github.com/discourse/discourse-adplugin.git
      - git clone https://github.com/jameshahn2/discourse-microm.git
      - git clone https://github.com/synweap15/discourse-voice-record.git
      - git clone https://github.com/paviliondev/discourse-follow.git
3 Likes

Any idea which plugin caused the problem?

I try safe mode and still have the problem

1 Like

yes, you need to dactivate or disable the plugins/theme one by one until you find the plugin/theme that causes the issue to come back.

I deactivate all plugins and still have the error.

try to remove all from : containers/app.yml
but don’t remove the : - git clone https://github.com/discourse/docker_manager.git
and ./launcher rebuild app

I did so

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.