User profile page is not found (404) - emails not showing

One of my users contacted me - their avatar suddenly became “standard” (silhouette icon) - Button to PM the user is greyed out. I went to the admin, searched her up and tried to reveal the email, because I thought because of the avatar change the forum email might have changed, but nothing happens when I click show email. This is in the console:

Clicking her profile from the forum or from the admin page (Show public profile) gives me a 404.

I am worried this is also happening to other users, but I haven’t heard of anyone else yet. I found one other that looks the same.

What could be wrong? The software should be up to date.

She can still read and post. I can’t change her username or impersonate her.


Is this a new user? What trust level is the user? Anything weird about the account when visiting the admin tab for their account?

Well, because I cannot click her name, I can only search her up in the admin - users interface - from there, I can see that her avatar is indeed wrong (the silhouette). The admin page doesn’t look particularly weird apart from that.

She’s trust level 3 - regular.

The account is about 4 years old, so not new - she’s a very active user with tons of posts. It’s a pretty recent thing, because she’s also been pretty active in personal messages. Of course you can’t send her anything anymore, because of this.

She can still use the site, like read and reply. The system even sends her emails.

I am just seeing now, that she is not the only one - Someone created a topic on my forum about it:

Are you on the latest version of Discourse? Please update to latest if you are not.

Are you running any third-party plugins?

I’m using the latest. I’m running:

Retort is a possible source, I guess? You could try quickly rebuilding with retort disabled and see if that helps?

I disabled it, then did ./launcher rebuid app - but still the same.
Is it enough to disable from the web interface or should I comment out the line in app.yml?

EDIT: Commented retort out in app.yml and rebuilt again - same thing :frowning:


This is a weird one maybe you can look into it Monday @dax?

There is nothing obvious about the reason why the profiles of these 2 users returning a 404 error. Can you check the site logs and see if you find something relevant when you click on their avatars?

I’m experiencing the same issue on some old accounts as well: I can access the admin page, but the email field won’t show, and the user profile returns a 404. I have an unconfirmed suspicion that this is somehow caused by usernames that are identical except for an underscore (in my case ‘MissB’ and ‘Miss_B’ - the underscore is a remnant from a vBulletin import). Both accounts had this issue, but on one of them it has since disappeared (the one with the underscore is still having the same problem).

I can see there are a smokyblue and a smoky_blue - there were also a Pro_Vapes user that had the issue, but his profile works now?!

I found another one, MixedUp (now called MixedUp1?) And Vapemixer is another user.


They’re easy to spot with that avatar …

Jyst FYI - I am using SSO.

Oh, so maybe SSO is interfering here and changing the state of the accounts somehow?

Migrated accounts from previous software that are not active is a different issue @bartv

I don’t think that’s the issue here - the MissB account was created after the migration (sorry, I wasnt’ specific there).


  • MissB - created after migration
  • Miss_B - created before migration

When I rename MissB to MissBTest I can show the email and user profile. When I rename it back, the problem returns (also, MissB can’t log in with his username, logging in with email worked or reset his password).

Why not? Do the emails not match on the account? For old migrated accounts, as long as you control the email associated with the account, you should be able to get back in.

MissB is not a migrated account. Apparently he could not log in using a username+password, but he finally did succeed with email+password.

I have a sneaking suspucion that some username lookup returns > 1 results when usernames only differ by one _ character, and that this breaks things.

1 Like

So you think this is related to having two nearly identical usernames? :thinking:

@daath is this also a pattern in your examples? Near identical usernames and duplicate accounts?

1 Like

Hard to tell - I don’t think the nearly identical usernames is the reason in one of the cases, but then again, his profile suddenly works again.

When Discourse detects a username from my main site that clashes it just named it “UsernameX” where X is the next available number that makes an available username (my main site doesn’t have usernames, but display names that doesn’t need to be unique).

My feeling is that something else is going on, but I can’t spot what it is. The accounts I’ve spotted were all over a year old though.

The problem on my site isn’t widespread, but it’s super annoying to the active ones (though only SmokyBlue comes to mind right now).

1 Like

I have done nothing, really, and right now her profile is working:

Profile page:

Activity page:


Note how her avatar in the thread is still borked.

And now, a minute after it stopped working?! What is going on? :confused:

1 Like