Infrequent translation updates in stable branch


(Passante) #1

I wonder why transifex translations in Stable releases are broken since 2 or more releases while Betas have updated translations.
I cannot understand the reasoning behind that. I see a lot of people complaining about while the betas are perfectly working :anguished:.


(Kane York) #2

Hmm, what barriers would there be to delivering translation updates to the stable branch @techAPJ?


(Sam Saffron) #3

Mainly cause we have not figured out a clean process for this.

I agree though we should if possible backport translations, the tricky thing though is that “meaning” may change across releases and sometimes we are not careful enough about creating new keys.

So for example, stable may have:

en: 
  keyname: 200

beta may have

en: 
   keyname:
     title: 200
     spelled_out: two hundred

This kind of change can not be backported.


(Passante) #4

Is understandable , but moving to beta branch the it translation of to main buttons to start a topic is still missing :facepalm:


(Kane York) #5

Where is that? We shouldn’t be attempting to translate lang.undefined.


(Daniela) #6

Here:

and now this link don’t work:

when you click it, nothing happens. I tried another discourse italian forum, the result is the same. :frowning:


(Gerhard Schlager) #7

The “New Topic” button looks fine here on meta.

Looks like you’re using a customization to add icons and a second button (the one with the envelope). Take a look at those. Maybe there’s a problem with them…

Clicking the search options doesn’t work for languages where the search help isn’t translated yet. The fallback to English doesn’t work. This is a known problem:


Search help doesn't work for some locales
(Daniela) #8

We use 2 new bottoms (before New Topic botton) and other customizations to add fontawesome icons.
I have deactivated all the customizations but nothing’s change.
The second botton (the envelope) it’s not a customization. Since I can remember it is appears on stable branch when we lost the translation (many months ago) and still remained when we switched to the beta branch yesterday…

Sorry, I lost this thread.


(Gerhard Schlager) #9

Well, there’s an Italian translation for “New Topic” in beta, it’s been there since November 2014 and it works here on meta.

Do you have any plugins installed? Try disabling them. I’m quite confident that it’s either a plugin or a site customization that is causing this.


(Daniela) #10

Actually the plugins are:

  • alert
  • checklist
  • pm bottom (maybe this is the reason for the 2nd botton after New Topic?)
  • Spoiler Alert!
  • discourse-tagging
  • docker-manager
  • lazyYT
  • poll
  • trout_emoji
  • vb_emoji
  • solved plugin

In the next days we will try to disable them, thanks.


(Daniela) #11

The problem was PM button plugin.
Now the translation is correct.

Thanks @gerhard :+1:


(ljpp) #12

Are stable branch translation updates lagging behind? Our team has submitted some crirical fixes.


(Sam Saffron) #13

In general we do not backport translations to stable.


(ljpp) #14

Oh. I remembered just the opposite. Dang. Good fixes to our locale (FI).