Not receiving notifications for announcements


(Leo McArdle) #1

I have #feature:announcements set to Watching, but for the past 3 or so sets of release notes (like this one) I haven’t received a notification for it, and have only found it in my New list.

Once I open the topic, it says that it is set to Watching, despite my not receiving a notification for it.


Does reassigning a category send a new email out to the group watching the new category?
(David Taylor) #2

I would guess that the post is being drafted either as a PM or a ‘shared draft’, and therefore notifications are not being sent. See here:

and more recently here:

It looks like @tgxworld applied a related fix here

I just tried a few things locally:

  • Watching #announcements
    • “Make PM Public”, then recategorise to #announcements
    • No notification received :x:
  • Watching #annoucements
    • “Publish shared draft”
    • Notification received :white_check_mark:
  • Watching first post #announcements
    • “Publish shared draft”
    • Notification not received :x:

(Joshua Rosenfeld) #3

@david very likely has the right idea. The last 3 or so release notes were created using the shared drafts feature. Previous notes were drafted elsewhere and posted “normally”. It looks like @tgxworld’s recent change likely fixed watching #feature:announcements, but we should probably fix the other 2 issues.


(Sam Saffron) #4

@tgxworld I would like you to fix this, this week if you have some time

A minimal fix here is that if a topic with 1 post is recategorized to a “watching” category notifications should go out.

It is a bit tricky here cause, what happens when you move something to #feature:announcements and then move it out of #feature:announcements ? We need to remove the watching status from all the people to be “correct”


(Jeff Atwood) #6

There is also the two full seconds of 307 SQL commands that somehow issue when you rename and recategorize a topic.


(Alan Tan) #7

@david Was this not working for you even with FIX: Retrigger notification when a topic is recategorized. · discourse/discourse@ee1eb1a · GitHub applied?

This case is fixed in

I tested this locally and it looks we we already do this.


(David Taylor) #8

I just tried again and this works fine, so I must have messed something up when testing. Sorry for the confusion!


(Alan Tan) #9

No worries! Thank you for working out the 3 scenarios!


(Leo McArdle) #12

Unfortunately it doesn’t look like this is completely fixed, as it happened again for me with: Discourse 2.1.0 beta 2 Release Notes (I got no notification, only appeared in New, appeared as Watching once I opened it)


(Jeff Atwood) #13

I’m 80% sure this has to do with posting as a ‘shared draft’, perhaps?


(Sam Saffron) #15

@david can you have a look at the shared draft case?


(David Taylor) #16

It looks like most of the cases described above regressed 2 months ago, but this wasn’t picked up in the tests (because Sidekiq jobs don’t run normally in a test environment). Here’s a PR to fix:


(David Taylor) #17

This is now merged, so future #feature:announcements should trigger notifications correctly :slight_smile:


(David Taylor) #18

This topic was automatically closed after 14 days. New replies are no longer allowed.