Troubleshoot docker installation issues

I just ran:

    cd /var/discourse
    git pull
    ./launcher rebuild app

And am getting:

Your Docker installation is not working correctly

What do I do?

First things first … scroll up.

The error will usually contain multiple lines, the last line just points you here, previous lines point at the actual issue.

Second thing … can you run a trivial container… try.

docker run -it --rm hello-world

If this is not working, your docker installation is broken.

First start by googling the error you found, remember there is a very active community at that may either have had this issue or can help you out.

Maybe you are out of disk space?


./launcher cleanup

Very often the problem is solved by restarting the docker service

sudo systemctl restart docker.service

I just experienced this error. Here is the error details _ docker: failed to register layer: Error processing tar file(exit status 1): write /usr/local/rustup/toolchains/1.65.0-x86_64-unknown-linux-gnu/lib/ no space left on device

My server has 50GB of space and my community would not have grown this much.

When I run the command - ./launcher cleanup - I receive the warning “WARNING! This will remove all stopped containers.”

I am not sure the implication of removing stopped containers and I will appreciate any help.

I have checked. My /docker is 42GB!

I fixed the problem by running ./launcher cleanup.

Then, I responded Y to “WARNING! This will remove all images without at least one container associated to them.”

It reclaimed 22GB!