Topic List Previews

Fantastic feature merefield! I haven’t been able to find any bugs (nice work) but have a couple of questions:

  • I love that you can add a category and all the subcategories will show, but can you show more than one category?
  • Is there any way to change the url to the portfolio page? like /images rather than /portfolio
2 Likes

No, I don’t believe you can (unless there is some magic delimiter hack I’ve yet to discover)

No, this is fixed.

However you can change the text label via the usual site Customisations.

3 Likes

No plans for this feature at present.

1 Like

Sorry to ear that, it would be very useful.

It seems similar to the user portfolio but at a global level.

I will continue seeking for it.

Thank you any way for the information and for this great plugin and its improvements.

2 Likes

It’s an interesting idea for sure.

One way to simulate that might be to visit Tag view for the ‘portfolio’ tag. However, I’m not sure there’s an easy way to make that home without plugin assistance.

Not all the way but there’s already a ‘featured’ tile system, that makes important stories take up two columns instead of one (you tag those Topics with the tag set for this purpose in the settings).

One way of making things happen sooner is to hire us on Pavilion.

1 Like

Thank you, Robert.

I know, but we have no budget (very short anual budget for maintaining the forum).
We have no incomes, just a little anual subscriptions from some users that opt to help the forum.

We cannot hire a developer.
But we can donate some money to the plugin, if you provide us a way for doing it (we are using it and are happy with it).

2 Likes

That’s very nice of you to say so and thank you. We no longer take donations on individual plugins, because this wouldn’t easily scale as our org gets bigger and there’s more of mix (we hope) of different devs maintaining plugins, but we do take donations to our organisation which is made up of both open-source volunteers and full-on freelancers. Read more about us here.

2 Likes

I am testing new Select thumbnail feature, but it does not seem to work always.
I have this topic which includes two Youtube video links. By default, no thumbnail is shown on the tile view.

If I use Select thumbnail, it presents me with two YT thumbnail images to choose from:

But even if I select one and save, it does not get shown in tile view.
Is there some limitations with YT preview images or remote/onebox images in general?

1 Like

It’s not very new :smiley:, was released in July :slight_smile:

Cannot reproduce. Can you share the YouTube link?

Have you rebuilt the post? Are you on latest of everything? There was a YT issue introduced by a change in Core which was subsequently patched and YT images worked fine again (however even then, you only needed to rebuild the OP).

1 Like

It is new feature to me, as I was on test branch until recently.

I have tried to rebuild both post in topics, but it does not seem to help.
Videos in topic are:


I notice some 404 errors - it seems images are moved to tombstone:
[15/Oct/2019:10:09:54 +0000] "pojalabanda.com" 77.111.24.83 "GET /uploads/default/optimized/1X/00ee76d3d97e06da6e287c6d78c648f4b14ebd20_2_400x300.jpeg HTTP/2.0" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/77.0.3865.90 Safari/537.36" "-" 404 611 "https://pojalabanda.com/" - 0.000 "-" [15/Oct/2019:10:09:54 +0000] "pojalabanda.com" 77.111.24.83 "GET /uploads/default/optimized/1X/49acf4e0590093f4a11f7c6e461a89007cea2da4_2_400x300.jpeg HTTP/2.0" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/77.0.3865.90 Safari/537.36" "-" 404 611 "https://pojalabanda.com/" - 0.000 "-"

tombstone image 1
tombstone image 2

2 Likes

Very odd, as you may remember that was fixed in the past. Wonder if we have a regression? Will take a look when I get chance.

1 Like

Yes, it looks like the problem we had before. Reference to old problem.

2 Likes

It looks like only one of the YouTube videos preview thumbnails are getting an entry in the post_uploads table.

Ordinary pictures do not suffer from this: you get as many entries as there are pictures.

For now, workaround to try is putting the second youtube into a new post (on same Topic).

However, that raises the question, where are the thumbnail entries (as well as the original uploads)? I’ll keep investigating.

3 Likes

But, there is only one YT video in each post already in the problematic topic. Select thumbnail shows images from both posts, but I cannot select either of them to make it work…

2 Likes

Thanks. Yes I can reproduce in the case of YT thumbnails. Interestingly there is no issue with normal pictures in that regard. I’ll take a look when I have more time.

2 Likes

Would it be difficult to add the ‘‘following’’ section from the “follow plugin” to the list of choices for topic tiles? The style is so gorgeous and would be nice to have it congruent throughout the website.

2 Likes

Is there a way to activate topic content excerpts in the “Latest” mode of the landing page (like https://meta.discourse.org/latest)?

2 Likes

Is there a way to activate topic content excerpts when a category is filtered by tags?

2 Likes

Yes and yes. Have you followed the guide in the OP?

2 Likes

Hmm, for some reason I don’t have “tags” as option in the setting “Show topic excerpts in selected lists in this category.”

As for the landing page (= main page), I don’t understand where to find the corresponding setting.

But I’m not admin here, maybe that’s the problem?

1 Like