Topic List Previews

I’m on an aging iPhone 7 iOS 13.2 and your tiles look great so almost certainly a client platform specific issue. Your users may be blissfully unaware.

3 Likes

Tried on Android 9 tablet and looks OK. It may be Android 10 specific.
Is there any plan to support 2 columns on tablets with 7" or bigger screen?

If the device reports itself as mobile you get the mobile view. Perhaps use a browser that reports itself as a desktop device? (eg like iPads). Or force it with the query param (?mobile_view=0)

We’ll be sticking to single column for mobile as it’s very hard to code the right column proliferation algorithm across so many different device with media queries. We tried that and always ended up with some android phones getting crushed two column experiences.

1 Like

In most web browsers you have the option “show as desktop pc” or similar.

By the way, the upcoming user portfolio sounds great.

But it would be wonderfull to have a global home page working in similar way:
Staff tags the posts they want with say “dashboard” tag, and a page /dashboard shows them like tiles or the way you want to show them.

That would be great. Does new version provide it? If not, are there plan to implement it?

May we test the upcoming version? How may I install it?

1 Like

New Feature Released :tada: :partying_face:

"TLP for Activity Topics and a new view “Activity Portfolio” (TLP features are Desktop only!)

The new view “Portfolio” gives a view of a user’s Topics filtered by either a site chosen Category (where users post their top Topics) or by specific tag (e.g. ‘portfolio’).

Settings

New views

image

There are now a couple of new views you can add tiles, thumbnails, excerpts etc. to

Portfolio

You can filter the User Portfolio by Tag or Category (slug).

You can disable the Portfolio feature if you wish.

Discoverability

The Activity page is oft-forgotten about and underused in my experience, so to enhance discoverability I’ve added a ‘Portfolio’ ‘button’ to the User Card (@bartv’s idea, thanks Bart!) . Disabling the Portfolio feature will hide this ‘button’.

image

I’m not 100% happy with the formatting here but there was a time constraint.

How do I get it?

Just upgrade the TLP plugin or rebuild your site, it’s fully released.

Why only Desktop?

Well, the Portfolio view will show on mobile, but the actual TLP features are sadly not implemented yet.

Implementing this on mobile with the current Discourse core base would require template overrides as currently the mobile activity lists are not made up of nested Ember Components which we rely on to make our stealth changes. It makes it much more invasive to deliver. We generally don’t like delivering such overrides to open source plugins because they are very risky to support and unstable for users as changes in core can very easily break the plugins or the plugin can break or hide changes to core.

It might be possible in the future if the Core structure were enhanced to adopt nested Components. I might even consider preparing a PR to Discourse if they were happy to make that change. This is a big piece of work though and would need to be funded.

Thanks to

@bartv, @p16 for funding this plugin enhancement
@angus for reviewing the PR

PR

Bugs

This was a big change, let me know if you come across any new bugs.

7 Likes

THANK YOU! We’re super super excited about this and will start rolling it out asap. I noticed that you even support sub-categories for the category-based view, which makes this 1000% better for us even. :pray:

1 Like

My pleasure, Bart! And thank you and @P16 for supporting the community here too! (love the gif! :rofl: )

2 Likes

Fantastic feature merefield! I haven’t been able to find any bugs (nice work) but have a couple of questions:

  • I love that you can add a category and all the subcategories will show, but can you show more than one category?
  • Is there any way to change the url to the portfolio page? like /images rather than /portfolio
1 Like

No, I don’t believe you can (unless there is some magic delimiter hack I’ve yet to discover)

No, this is fixed.

However you can change the text label via the usual site Customisations.

2 Likes

No plans for this feature at present.

Sorry to ear that, it would be very useful.

It seems similar to the user portfolio but at a global level.

I will continue seeking for it.

Thank you any way for the information and for this great plugin and its improvements.

1 Like

It’s an interesting idea for sure.

One way to simulate that might be to visit Tag view for the ‘portfolio’ tag. However, I’m not sure there’s an easy way to make that home without plugin assistance.

Not all the way but there’s already a ‘featured’ tile system, that makes important stories take up two columns instead of one (you tag those Topics with the tag set for this purpose in the settings).

One way of making things happen sooner is to hire us on Pavilion.

Thank you, Robert.

I know, but we have no budget (very short anual budget for maintaining the forum).
We have no incomes, just a little anual subscriptions from some users that opt to help the forum.

We cannot hire a developer.
But we can donate some money to the plugin, if you provide us a way for doing it (we are using it and are happy with it).

1 Like

That’s very nice of you to say so and thank you. We no longer take donations on individual plugins, because this wouldn’t easily scale as our org gets bigger and there’s more of mix (we hope) of different devs maintaining plugins, but we do take donations to our organisation which is made up of both open-source volunteers and full-on freelancers. Read more about us here.

1 Like

I am testing new Select thumbnail feature, but it does not seem to work always.
I have this topic which includes two Youtube video links. By default, no thumbnail is shown on the tile view.

If I use Select thumbnail, it presents me with two YT thumbnail images to choose from:

But even if I select one and save, it does not get shown in tile view.
Is there some limitations with YT preview images or remote/onebox images in general?

It’s not very new :smiley:, was released in July :slight_smile:

Cannot reproduce. Can you share the YouTube link?

Have you rebuilt the post? Are you on latest of everything? There was a YT issue introduced by a change in Core which was subsequently patched and YT images worked fine again (however even then, you only needed to rebuild the OP).

It is new feature to me, as I was on test branch until recently.

I have tried to rebuild both post in topics, but it does not seem to help.
Videos in topic are:


I notice some 404 errors - it seems images are moved to tombstone:
[15/Oct/2019:10:09:54 +0000] "pojalabanda.com" 77.111.24.83 "GET /uploads/default/optimized/1X/00ee76d3d97e06da6e287c6d78c648f4b14ebd20_2_400x300.jpeg HTTP/2.0" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/77.0.3865.90 Safari/537.36" "-" 404 611 "https://pojalabanda.com/" - 0.000 "-" [15/Oct/2019:10:09:54 +0000] "pojalabanda.com" 77.111.24.83 "GET /uploads/default/optimized/1X/49acf4e0590093f4a11f7c6e461a89007cea2da4_2_400x300.jpeg HTTP/2.0" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/77.0.3865.90 Safari/537.36" "-" 404 611 "https://pojalabanda.com/" - 0.000 "-"

tombstone image 1
tombstone image 2

1 Like

Very odd, as you may remember that was fixed in the past. Wonder if we have a regression? Will take a look when I get chance.

Yes, it looks like the problem we had before. Reference to old problem.

1 Like