Topic List Previews

Hmm, for some reason I don’t have “tags” as option in the setting “Show topic excerpts in selected lists in this category.”

As for the landing page (= main page), I don’t understand where to find the corresponding setting.

But I’m not admin here, maybe that’s the problem?

1 Like

Here’s a working example: Topics tagged zero

This works if this is set globally in Settings -> Tags

image

Just add latest to ‘topic list excerpt’ setting.

Make sure you are confirming the addition with the green tick

2 Likes

This seems to already be set, because filtering the topic list by tag works fine:
Before filtering:
image
Only the excerpts are gone after filtering:

image

W.r.t. the landing page, you wrote:

I’ll have a look at this with my admin later, thank you.

2 Likes

One last porftolio question/request merefield; I don’t see a way to hide the new nav pill with css easily, would it possible to get an option to hide this? I already have too many nav pills and I prefer to put a link to this in my header menu instead. Thanks!

1 Like

Yeah its on mobile devices.

2 Likes

Users are reporting problems with selecting a thumbnail. Sometimes it fails, but we haven’t found steps to reproduce yet. We do have the console output of one case. Have you seen this before? Any idea what could lead tot his?

1 Like

Ah, we found out:
The setting “topic list excerpt” showed “latest”, but only as the first line of the dropdown box! So “latest” was not active yet!

2 Likes

Yes that’s a significant gotcha with the setting style :). Glad you sorted it.

1 Like

Bart we have a known issue with YouTube but please point me to a problem Topic.

Those error messages don’t immediately seem familiar to the TLP code. Can you reproduce them?

1 Like

It’s very irregular, even within the same topics so we’re having a hard time to reproduce this issue. I’ll keep digging, but wanted to report it in case someone else runs into this too.

2 Likes

Hi, Robert
can you show me how to change topic list featured images tag position to top like this

1 Like

That’s unfortunately not entirely trivial. You’d need to fork the plugin.

They are currently anchored on

image

You could try to move that to top-notices

image

But I’m not sure of the other consequences to layout. But if you are happy maintaining your own fork and experimenting, go for it!

1 Like

thanks for your reply, i think it’s difficult for me, i will try oneday, not now.
Thank Robert, have a good day!

2 Likes

Here’s a few customizations for the portfolio feature some may be interested in.

Clean up the user card buttons to make the message button smaller and remove the portfolio text so the buttons do not cover up the users name.

.portfolio-button-inner {
    width: 25px !important;
    min-width: 18px !important;
}

.portfolio-button-inner label {
    display: none !important;
}

.usercard-controls button {
    min-width: 120px !important;
}

Hide the Nav pill for portfolios

[title="portfolio"] {
  display: none;
}
6 Likes

Hi @angus ,

thank you very much for this plugin, We like blenderartists are using this plugin at krtia-artists.org .

The plugin is working correctly except in two cases we didn’t get thumbnails for the image the user has posted. We tried to re upload the image but it did not help.

you can see the post - here , I can’t post the other one due to link limit.

May I request you to help us to find the reason why these are not getting the thumbnails? Are there any restrictions of size, dimensions or image format?

thank you once again for creating this.

1 Like

Have you rebuilt the first post? What happens when you ‘select thumbnail’?

2 Likes

Hey @merefield thank you very much, that sorted it out. Selecting thumbnail and rebuilding did the trick. I had tried the rebuild html option earlier but it hadn’t worked. Thank you

2 Likes

Adding a category to show excerpt on latest does not seem to work for me, category page changes but the latest on the homepage does not change, am I doing something wrong?

Also my suggestions excerpts are disabled everywhere, it seems to show 1 or 2 excerpts on suggestions (mobile) anyway, is this bug known?

1 Like

Would just like to confirm this issue on my forum. Sometimes select thumbnail does nothing and this happens also with regular images (not YT preview images). For this topic I was unable to select specific photo - tried two times, but I was able to select some other one. Only then selecting the wanted photo worked.

1 Like

@Lure That seems to me that maybe the image selector was not cleared. I don’t know how the TLP works behind the scenes to select thumbnails, but I assume there is an img element behind the scenes.

When the img element has a file selected and you try to select the same image again without clearing the img element beforehand, it won’t trigger a change (so it would be like no action was executed by the user). But if you choose another image and then choose the first one the change will be triggered. In SPAs (like discourse) it could be worse if the same img element is used for different pages.

Your issue seems like this, but I don’t know if the original issue is the same. Also, this would only happen if you selected the same image before, so I don’t know if this is really your issue, just my 2 cents. If this is really the issue, the img element should be cleared by the plugin even if the upload was canceled.