Topic List Thumbnails Theme Component

I turned off the third utility here: Topic List Previews. The interface is no longer broken.
So will the thumbnails images be processed sequentially or manually? Most of the time, there are no thumbnails images ?

Oh, I see it. I must say that this theme is great, thank you. :smile:

T贸m t岷痶

Update 1: Is it optimized image? I haven鈥檛 seen the code but it seems the thumb image is currently processing slowly, I will wait

Update 2: Still not done yet, is there a faster way to create it? Like raid post and so on. Some topics Recreate HTML but no changes

Update 3: Must select Grid for the category to execute image creation :smile:

Update 4: When you enter the topic and return to it, the thumb is created. But when f5 pages, the image is lost

Update: Is due to conflicts between plugins. Successfully resolved.

1 Like

Great, glad it鈥檚 working!

Image resizing is run in the background, yes. However, you should start seeing images immediately (we will use the full-resolution versions rather than the resized ones).

If you鈥檙e missing images from topics, it is either because there are no images in the first post of the topic, or because the images are 鈥榟otlinked鈥 from another site. You should enable the download remote images to local setting, and then 鈥渞ebuild html鈥 on the topic.

10 Likes

I don鈥檛 know if it could be a mistake, but I have 4 subcategories, I wanted to apply this to only one of these, but for some reason it applies to the whole category in general

Hi, I made a try with 2.5.0.beta4 but no joy. The extension is not in the list of repository

Fantastic theme component!

One slight glitch I鈥檓 seeing on mine is thumbnails showing up on mobile even though I鈥檝e unchecked the box 鈥淓nable thumbnails on mobile devices鈥.

I still see them when on my iPhone on the discourse hub app. I鈥檝e got the thumbnail mode set to 鈥渓ist鈥 and I鈥檓 hosted on discourse (so running 2.5.0 beta4).

Apart from that it鈥檚 an awesome theme component. Just what I needed for my community.

3 Likes

Thanks for the feedback everyone! I just made a batch of improvements.

A couple of thumbnail selection improvements in core:

Unfortunately not, although I am planning a new component for featuring topic images at the top of a category :eyes:

Not with this component, but check out Topic List Excerpts Theme Component

Correct

Not sure what鈥檚 happening there鈥 can you share a link to your site?

Check the instructions here to learn about installing a theme component from a git repository. You can find the repository link at the top of the topic here.

That should be fixed with:

15 Likes

It had been a mistake on my part, I had not seen the option to set a default layout in all categories :sweat_smile:

2 Likes

Just noticed that the thumbnails in the topic lists for #theme are being served from amazon S3:

https://assets-meta-cdck-prod-meta.s3.dualstack.us-west-1.amazonaws.com/optimized/3X/0/9/098f8167ccce99ec3e4416f2e6943595561bb6c9_2_600x480.jpeg

While the actual images in the topics are being served from Cloudfront:

https://d11a6trkgmumsb.cloudfront.net/original/3X/0/9/098f8167ccce99ec3e4416f2e6943595561bb6c9.jpeg

Is there a way to have the thumbnails use a CDN url instead of being served directly from S3?

Thanks!!

5 Likes

Good catch, thanks @internet_cookie. I just fixed this in core so that we use the CDN for topic images:

13 Likes

Awesome! thanks so much

1 Like

After enable , the class is lost.
Specifically, only topic-list instead of topic-list topic-thumbnails-list

Do not understand its 2 different components. topic-list-item and topic-list

I find everything ok just missing the class, if any it works.

love love it锝烇綖锝烇綖
the meta is always surprise鈥 :kissing_heart:

2 Likes

What about posting without pictures but with a link to youtube or TED? Will it take a thumbnails from videos?

1 Like

For YouTube, yes. For other video embeds, not at the moment.

6 Likes

I tried to put in the first post of the topic a link to youtube video like this:


but thumbnail didn鈥檛 created. After that I added an image to the post and thumbnail was created.
So there is a problem with youtube links.

Let me see if I can address this.

The following is irrespective of this Theme Component.

The thumbnails are only created when the image file is local.

With YouTube embed there is a delay before the remote image (hosted on YouTubes servers) is first uploaded to the Discourse server in a sidekiq job.

Only then can a follow-up process pick up the uploaded image and create the thumbnails.

This is necessarily asynchronous and it鈥檚 designed to protect the user experience and the server load.

It is possible you simply did not wait long enough for all this to happen.

Can I suggest you try it again and wait a few minutes? (And then refresh the topic list)

7 Likes

I tested it about 6 hours ago, left the link in the post. No thumbnail generated.

1 Like

There is some filtering employed. The filter might have discarded it for not meeting the criteria. Try another video.

I will say that I鈥檝e had countless YouTube thumbnails created on my sites now.

I鈥檓 assuming the post is a new one and not old?

2 Likes

Tried with an old one. But now did it with a new post. Waited for 10 minutes - no thumbnail.
What should I check?

Are you running the latest tests-passed version of Discourse? The YouTube issue was fixed recently

7 Likes