Knowledge Explorer Plugin

I agree it would be more user friendly to use category slug instead of category id, guess so people can form urls manually or is there another reason?

The pavilion knowledge base plugin had a nice category based url structure that I liked and that I think would be handy here too. It includes an admin setting for the base url. It was possible to direct people easily to a specific kB category. But then it does not support tags at all.

Dear @justindirose,

thank you so much for conceiving this fine plugin.

We just enabled it in form of the Hiveeyes Knowledge Explorer and found it promptly scales much better than the previous Hiveeyes Knowledge Base provided by the Knowledge Base Plugin. Also, we found it way easier to configure by having a central place where to adjust the categories than having to go to each category and finding and enabling the plugin on the category settings screen.

Now we are facing a problem and would like to share it with you. So, we are having this category FAQ zu BOB - Hiveeyes we just made available on the Knowledge Explorer, see »FAQ zu BOB« in Knowledge Explorer.

However, while the topic WLAN-Verbindung schlägt fehl - FAQ zu BOB - Hiveeyes is displayed within the Knowledge Explorer content area of this category, Firmware kann nicht aufgespielt werden - FAQ zu BOB - Hiveeyes as well as some others are not.

On the other hand, the Knowledge Base Plugin renders all of the six topics within the respective category, see Hiveeyes Knowledge Base.

So, we are humbly asking if you might have any idea why this might happen to us? Thanks already for taking the time to look into this!

With kind regards,
Andreas.

As an anonymous user, I am seeing the “Firmware kann nicht aufgespielt werden” topic among others. Is there a chance you may have muted the other topics?

1 Like

Dear @tshenry,

thanks for your quick reply.

So true. Thank you so much and sorry that I’ve missed to check this first.

Again, you are right. I have no idea how that might have happened. I just unmuted all things I’ve designated as FAQ’ed and everything I was missing just reappeared.

I am happy that everything seems to work as intended for me now. Thank you very much for your excellent help on our observations and sorry for the noise.

With kind regards,
Andreas.

3 Likes

I believe this happened to me because the feature Suppress category from latest has been taken away, so all these categories probably converged into the muted state automatically. See also Suppress category from latest topics gone.

1 Like

Dear @justindirose and all other Knowledge Explorer lovers,

Thank you so much

We have been very pleased to integrate this plugin into our instance of Discourse [1] and also made some canonical entrypoints on a dedicated subdomain which redirect specific resources to Knowledge Explorer [2]. This is excellent, thanks for contributing this to Discourse, @justindirose!

While ramping this up, we had two kinds of observations we would like to share with you.

Resolving link titles

When inlining links to categories and topics, Discourse will resolve the link titles conveniently like

However, when using inline links pointing to the Knowledge Explorer, it just resolves all link titles to the site’s name. This happens for both links to categories and topics.

Compatibility with DiscoTOC

When used together with DiscoTOC - automatic table of contents, direct navigation to in-page anchors from url hashes does not work. I.e., while url hashes can be used to navigate to

Do you see any way to improve resolving the title of the inline link target and make the url hash propagate through the page router into DiscoTOC?

Thanks already for taking the time!

With kind regards,
Andreas.

[1] https://community.hiveeyes.org/
[2] https://bee-observer.hiveeyes.org/

4 Likes

Thanks all for the input on the plugin! Just FYI I’m out on leave as my family had a new addition recently so it’ll be a while before I personally can look at any of these items.

10 Likes

Thanks for listening!

Sure. Congratulations to you and your family!

4 Likes

Hi there,

  Amazing Plugin. Thanks for your contribution!
  
   Anyone could help me with this little problem?  Much appreciate!
  My Expolorer doesn't show any contents.Am I missing some settings? 

Best Regards,
Lanco

Did you select categories and tags in your site settings for the plugin?

2 Likes

Hi @sam

Thanks very much for your reply.

Yes, we do have categories settings as last post shows. If not, Categories count in screenshot of my last post will be empty.

I found another site within this thread also has this issues. @
see at Hiveeyes

And both of us is using Discourse 2.4.0.beta. (beta8 & beta9)

I don’t figure out why Global Legal Empowerment Network Community Discussions don’t suffer this issue. Maybe his site has special settings? (Beta9)

Best Regards,
Lanco

Can you try safe mode? Looks like you have alot going on there and I suspect a conflict with another plugin or theme customization. It could also be related to language localization.

Aside: what is that margin notes plugin? That is pretty neat!

Update… your problem could be related to the content. Try it without oneboxed content or images and see if you can get it working at all. I did have problems in the past with embedded youtube videos but I think that has since been fixed.

3 Likes

Hi Tobias,

Thank you to point out onebox. I will have a test.

:face_with_monocle: :open_mouth: Which margin notes plugin do you interest? I don’t realize I’ve shown that thing in my screenshots.

Our community is bbs.marginnote.cn and forum.marginnote.com . If you found anything interesting. I’m willing to share with you.

Update: According to my test. An extremely simple post also has the issue.

Now I’m trying rebuild discourse with less plugin.

Best Regards,
Lanco

1 Like

No need - just use safe mode at /safe-mode and you can choose to see the site without plugins and theme customizations.

I just rebuild app only keep one plugin, K. Explorer…But succeed to show contents. Now I’m working on test which one conflicts.

Lanco

2 Likes

Found one conflict:

No others. Just QA plugin conflicts. No matter how I change the QA settings, only if I disable it, the K. Explorer plugin show contents.(Even the related categories is not QA enabling.)

Our forum has one catalog based on QA plugin. And it already has many posts in. It’s hard for me to abandon QA plugin, Hope lovely author could fix this. @justindirose And happy new year, sorry for disturb you!

Lanco

1 Like

Nice job troubleshooting! This may also be a QA plugin issue. If it is, @angus and his pavilion colleagues would no doubt appreciate a bug report at Bug Report.

1 Like

Indeed this specific topic does not render there. Thanks for spotting this! However, all others seem to work flawlessly, right?

Maybe an issue with the solved plugin?

Generally, this plugin works pretty well but it is also still fairly new, so we can expect there to be some kinks. Meanwhile holidays and lifestyle changes :baby_bottle: for the plugin creator, so we have to be patient. :wink:

I made a list of confictions:

Hard Reject (Must disable)

May cause loadinng problems if enable for related category:

  • Vote (First time of loading)
  • Solved (Everytime of loading)

Sir, I’m not sure is there any other loading issues in your site. @amotl
Please ensure your KE related categories have disabled these plugins. :grimacing:

List of ensuring to be fine:

Lanco

2 Likes